W5200 Module

Hi I have got one of Wiznet's new W5200 packages the WIZ820io and I cannot seem to figure out how to connect the power down pin on it and allow my arduino to shut down the module. Would I just connect it to one of the digital pins? How do I wake it up? Also if it has a DHCP lease will it have to get a new one when it powers up again?

The Wiznet 5200 is 5v tolerant on the input pins.

You should be able to select a digital pin, connect it to pin 45 on the W5200, and set the pin to OUTPUT. Set the pin LOW to enable the W5200. High powers down.

I have not used that IC, but I presume the IC will need to be reinitialized after a power-up.

Eight sockets! WOW!

Hey thanks. Yes it is a really nice little package.

Also what is the interrupt pin for?

The W5100 does not use the interrupt pin with the Arduino. The Arduino software polls the device instead. I presume you would want to use the same interface protocol on the W5200. But then, the person who writes the initial code gets to decide stuff like that. :)

Are there w5200.h and w5200.cpp files available from Wiznet?

Hey Yes they have written libraries for it that you just replace the W5100 files in the IDE http://www.wiznet.co.kr/Sub_Modules/en/product/Product_Detail.asp?cate1=5&cate2=42&cate3=0&pid=1161#tab

If you have problems with that code, let me know.


I would just like to report back on these modules, THEY ARE BRILLIANT, screw the ethernet shield, lower power consumption from what I have tried and faster DHCP pickup as well as cheaper and don't forget the power down option which I still need to implement/play with.

mrjonny2: I would just like to report back on these modules, THEY ARE BRILLIANT, screw the ethernet shield, lower power consumption from what I have tried and faster DHCP pickup as well as cheaper and don't forget the power down option which I still need to implement/play with.

Appreciate the update. I picked up a couple but have not had time to try them yet. Have been using the WIZ811MJ with good results up until now, but the WIZ820io has a much better form factor in addition to the more capable chip.


I got the W5200 module and want to build for that. I see that some newer files need to be added. However, I could not find the old w5100 files anywhere on my system http://arduino.cc/forum/index.php/topic,102312.0.html Tried moving my old Arduino directory aside and installing a fresh IDE1.0 distribution (on Mac). Same problem, no w5100.h and .cpp Under Arduino/libraries I don't see anything to do with Ethernet However, the test sketch still compiles - it just doesn't work with the 5200. I guess I must need a whole net set of Ethernet libraries but not sure where to find them. Any suggestions?

Thx. Paul

The libraries folder and contents should be in your install by default. This is where the ethernet.cpp and ethernet.h files are located. /arduino-1.0/libraries/Ethernet/

The w5100 files is in a subdirectory of that folder. /arduino-1.0/libraries/Ethernet/utility/

BTW, if you want the Ethernet.cpp and Ethernet.h files to compile for the w5200, you will need to upgrade to IDE v1.0.1.

Thx @SurferTim and @jcrouchley. It turns out that these libraries are in a completely different place on a Mac. /Applications/Arduino 1.app/Contents/Resources/Java/libraries/Ethernet/utility

I was getting confused with the libraries folder in the Arduino sketch folder, standard libraries don't live there.

The other complication was that the Mac Finder did not find the above folder.

Still not working but at least I think I have the right libraries. Will check versions again.


@Paul Tanner: Thanks for that info. I use Ubuntu, and the repository does the same to the repository version (was v0022).

I downloaded the latest versions from the Arduino site into a local /home/user/ directory and extract it there. Change to that directory, and run the 'arduino' shell script. If you run it, you get that version, at least on my flavor of Linux. Macs OS is just a cousin of Linux. Does that work on a Mac?

I'm using IDE v0022, v1.0, and v1.0.1-rc1 now. My IDE v0022 is in a similar location as on a Mac, hidden in "usr/".

edit: My v1.0.1-rc1 ethernet library is currently using those files on a w5100 with great success. :) That is determined by the

define W5200

in w5100.h. If it is commented out, it will compile for a w5100. // #define W5200

If you dare, here is the page with the links to the newest test release. IDE v1.0.1-rc2 http://arduino.cc/pipermail/developers_arduino.cc/2012-April/006444.html

Another testimonial for WIZ820io. I used patches from wiznet site for both 022 IDE and v1.0 IDE. Hooked it up to 3.3v/grnd from Uno and SPI pins (10-13) , and wiz820 reset to reset on UNO. as noted, io pins are 5v-tolerant. Simple UDP and TCP tests worked just fine. 8-byte UDP request-reply took about 564us (022 IDE), 892us (v1 IDE). Sending out 1000-byte UDP packets at about 3.5ms/packet. Inbound UDP 1000-byte packets with no drops at 2Mbs, which is probably consistent with SPI running at 4 MHz.

Also tested on Maple ARM

Another testimonial for WIZ820io.

...and for ekitzone. The real thing here is Wiznet. That is where I got the w5200 (modified w5100) files. Here is the thread that has the files I am using. http://arduino.cc/forum/index.php/topic,102312.0.html

Sorry I didn't reply to anything here guys. Life is chaos, but good to see everyone likes the new chip. The only thing that would be awesome would be an arduino ethernet with the W5200 onboard instead of a w5100 and the same for the ethernet shield. When I get the project I'm working on out the door I think that is what I'm gonna do.

In anticipation of your new Arduino, I have suggested the w5200 code as an enhancement to the ethernet library. :) http://code.google.com/p/arduino/issues/detail?id=898

edit: You can use that now if you wish. It requires IDE v1.0.1. There are 4 files needed for that enhancement. w5100.h w5100.cpp Ethernet.h Ethernet.cpp

You should be able to download them from the two posts on the link above. I forgot about the defines in the ethernet files. Thanks again, Gene!

Hi I have been using it for a while now. I have even implemented some of the 1.0.1 code into the libraries from wiznet in order to use the DHCP maintain function. I will hopefully begin work on the shield to start with during the summer

I have managed to come up with a set of schematics. If anyone wants to have a look maybe correct any errors there may be. Feel free.