Wave Shield can't open file

Greetings,

I am using the wave shield with an arduino uno to play a .wav file (which I converted earlier from .mp3). The file plays fine on my computer, but won’t open at all with the arduino. The message that shows up on the serial port is “couldn’t open file CARILLONS.WAV”. It comes from the code

  if (!f.open(root, name)) {
    putstring("Couldn't open file "); Serial.print(name); return;
  }

I think that the code just comes from it couldn’t open the file. Some other similar files play fine using it, just not this one.

ensure you converted the file to .wav with the correct specs that the wave shield needs

I tried converting it again (I use the same settings for each file, and the others all worked), etc., and it still doesn't work...

"CARILLONS.WAV" has a 9.3 format filename, not 8.3 It will be being munged into something else like CARRIL~1.WAV.

Either rename it to something in 8.3 or find out its proper 8.3 format equivalent.

How do you figure out if something is 8.3 or not?

8.3 = '8' characters, followed by a '3' character extension

12345678.123

thisis08.wav

Oh, okay. Thanks!