wavgat problems...

Hi,

same problem here, but with the above procedure was able to connect (not sure if there are hidden issues yet...).

Only minor annoyance (*) is that in Tools / Boards it shows both "Arduino AVR Boards" for Arduino and for WAVGAT.
Please, any idea on how and where to amend it?

Also, by the way, why are there two different folder (WAV and WAV8F) in hardware folder of update zip file?

Thanks and best regards,

Aingeru

(*) => after realising "Compatible Arduino UNO R3" in reality means "Not-100%-Compatible Arduino UNO R3", but in any case my fault for choosing cheap...

im new to arduino and coding.im facing the same problem with WAVGAT UNO R3 board.ive followed all the instructions and read all the post about WAVGAT UNO R3 boards but it seems that this board is having the worst problem.here is the warnings ive encounter and i cant solve it.

Warning: platform.txt from core 'Arduino AVR Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.

any suggestions about this.im not as good in coding.thank you

Well, that part claims to just be a "warning", so things should proceed anyway...

you can see the ON light is on but the light on L no light at all it means that its not working.if you upload blink its blinking but other uploads no.

Have you checked below post?
[WAVGAT pseudo-clone] Issues and Troubleshouting

after ive figure out about the troubleshooting again another problem occured

Arduino: 1.8.5 (Windows 7), Board: "WAVGAT UNO R3"

C:\Users\cam\Documents\Arduino\hardware\WAV\avr\cores\lgt8f\Print.cpp: In member function 'size_t Print::print(const __FlashStringHelper*)':

C:\Users\cam\Documents\Arduino\hardware\WAV\avr\cores\lgt8f\Print.cpp:44:23: warning: 'progmem' attribute ignored [-Wattributes]

const char PROGMEM *p = (const char PROGMEM *)ifsh;

^

avr-gcc: error: C:\Users\cam\AppData\Local\Temp\arduino_build_791809/core\core.a: No such file or directory

exit status 1
Error compiling for board WAVGAT UNO R3.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Thanks thanks thanks!
.
.
.

wireis:
I also had the same issue at first but I have found the solution...

Step 1

Download the following RAR file from the link below;
https://drive.google.com/open?id=10gwrG9uTDwaEO-7EudsmBkfgdcyrcABI

Step 2

Once downloaded, extract these and copy the content within the "update" folder (not the "update" folder itself just the content inside it)

Step 3

Paste content to the following path on your computer...
C:\Users\Administrator\Documents\Arduino

Step 4

Restart Arduino IDE Software

Open Arduino IDE, select your COM port if required and Select your WAVGAT board type (WAVGAT boards are at the very bottom of the board list)

Enjoy!

Hope this helps

W.

You need install the CH340 driver after upload

Hi, I have tried to use the arduino package from the google drive link, but some functions do not work, like serial print of a floating point variable.

My board as one 12Mhz crystal near the USB chip and a 16MHz near the microntroler chip.

I have looked in the board.txt that came with the package and it list the chip used as an LGT8FX8P even if on the chip itself it is written Atmel Atmega328P.

So I search for that chip and found an github project for arduino similar to the one from the aliexpress link, called LAdruino_HST https://github.com/LGTMCU/Larduino_HSP

This one works great with the latest Arduino, no warning, you have to select LGT8F328P-LQFP32 MiniEVB as an arduino board after the install.

You may have to delete the files from the other package before installing this one, in my case it was warning about files in double so I did...

Hope it helps some body.

Thank you.

Hi bookaroo,

please, could you upload some pictura of the actual board?

Did you have to change or upload the bootloader?

Could you indicate a step-by-step list?

Thank you very much.

Hi,
Lot of thanks for wireis.

His solution solved my problem.

Best regards.
Bernard.

Another problem is that the analogRead function behave abnormally.

It can work but:

ADC is 12bit. Readings make sens (in my case) only when I give it as AREF 3.3V (pin 3v3) and ad some code:

void setADC(){
  analogReference(EXTERNAL);
  analogReadResolution(12);
}

And read with

setADC();
analogRead(A0);

Score in range 0-4064 (why? i don't know).

If you use something using I2C then analogRead will not work on pin A5 and A4

Seems GPIO work at 3.3V (instead of 5V)
(Voltages not checked with multimeter yet!)

Multimeter show 3.01V in HIGH and -0.21V in LOW

Hope it help someone

Thanks Arthur310

Updated [WAVGAT pseudo-clone] Issues and Troubleshouting

Please, if possible could you also check voltage of GPIO (Digital outputs and inputs)?
We suspect it could also be 3.3V instead of 5V.

Also, just for confirmation, with your code would it be possible to make WAVGAT behave as a regular UNO?

void setADC(){
  analogReference(EXTERNAL); // Feeding AREF with 5V
  analogReadResolution(8);

Hi.

This is actually repeating what joemon posted earlier, using other words.
I spent several hours trying to program a wavgat. Following the instructions in this thread. Nothing worked.
Then I changed to another wavgat, and everything worked like charm first time.

An important observation is that the faulty wavgat did not lit up the yellow led "L" beside the red led, when connecting the usb-cable. The working wavgat flickered the yellow led when connecting the cable.
So that is a way of identifying a faulty wavgat. Hope that saves time for someone else...

BR / Mats

AingeruJM:
Please, if possible could you also check voltage of GPIO (Digital outputs and inputs)?
We suspect it could also be 3.3V instead of 5V.

It’s 3,3V

AingeruJM:
Also, just for confirmation, with your code would it be possible to make WAVGAT behave as a regular UNO?

void setADC(){

analogReference(EXTERNAL); // Feeding AREF with 5V
 analogReadResolution(8);

No feeding AREF with 5V give some wrong score.

It looks like here you have lot’s of answers:
http://www.ocrobot.com/doku.php?id=ocrobot:alpha:8f328p-u:main
This is it. ADC give 4064 as max score. Like there. Without feedeng AREF it works with ref 1.024\2.048\4.096 internal.
System logic level: Factory 5V (can be switched to 3V3 through the pad) but here looks like it’s factory 3,3V. How to switch it? I do not know. I am new to arduino. It’s my first board so I’m learning on this “thing”.

bookaroo give link: GitHub - LGTMCU/Larduino_HSP: Hardware support package for Larduino
this work but if I use this driver LCD I2C does not work properly (LiquidCrystal_I2C.h). Someone know how to fix it? It looks like this driver is better (no errors). If i use

#include <Wire.h> 
#include <LiquidCrystal_I2C.h>

LiquidCrystal_I2C lcd(0x27,16,2);  // set the LCD address to 0x27 for a 16 chars and 2 line display

void setup()
{
  lcd.init();                      // initialize the lcd 
  // Print a message to the LCD.
  lcd.backlight();
  lcd.clear();
  lcd.print("Hello, world!");
  lcd.print("ello, world!");
  lcd.print("ArduinoSolutions.com");
}

void loop()
{
}

on screen I can see only “HeA”. always only first letter.
EDIT
Update LiquidCrystal_I2C to 1.1.2 and it work OK

In both driver there is no way to use EEPROM.h. After reset read ‘0’ whatever write. But how long its work it give proper readings of what you write.So it looks like there is some kind of emulation of EEPROM only. Or I do not know how to use it. Any ideas?
EDIT
The EEPROM library found on one of the Russian-language websites has been helped here. I do not have any guys from where I downloaded it unfortunately. Because I made a mess in the libraries, I changed its name to EEPROM1.h. Work with those drivers GitHub - LGTMCU/Larduino_HSP: Hardware support package for Larduino
I did not try with those from seller.
It’s only basic but better than nothing. Example:

#include <EEPROM1.h>

void setup(){
  Serial.begin(115200);
}

void loop(){
 Serial.print(EEPROM.read(1));
 Serial.print(" - ");
 Serial.print(EEPROM.read(10));
 Serial.print(" - ");
 Serial.println(EEPROM.read(100));
 delay(2500);
 if(Serial.read()=='0'){
  EEPROM.write(1, 10);
  EEPROM.write(10, 03);
  EEPROM.write(100, 90);
  Serial.println("update done");
 }
}

@Mats_Lind

The working wavgat flickered the yellow led when connecting the cable.

mine does. yellow led bling some time when conecting the cable.

E2PROM1.zip (5.97 KB)

1 Like

I also bought me a few of those cheap Wavgat Uno boards knowing the risk I was taking. But for only $ 5 for the two including shipment I was ready to take the risk. And yes as expected it didn’t work when I connected it as an Arduino Uno. But when you read the backside of the board, there is a loud and clear text that says you have to connect it as a Wavgat Uno 3 in the software. Meaning you have to download the board from somewhere. And as Wireis clearly pointed out in his posting at page one of this thread you can download the correct files here https://drive.google.com/open?id=10gwrG9uTDwaEO-7EudsmBkfgdcyrcABI . I did that and pasted the correct files into the Arduino directory's and restarted the Arduino IDE and uploaded a sketch. And voila its working well. The CH340 issue may not be a problem anymore, that may be a well know issue now a days.

The only additional thing I have to say to the pasting of the files is that you must be careful not to just paste the Hardware and Library directory if there are already files in there. Only paste the files inside the downloaded Hardware and Library folder to the Arduino Hardware and Library directory’s, don’t overwrite your existing ones.

By the way, the information Wireis posted is also mentioned on the webpage of the Aliexpress seller. https://nl.aliexpress.com/item/WAVGAT-hoge-kwaliteit-Een-set-UNO-R3-CH340G-MEGA328P-voor-Arduino-UNO-R3-USB-KABEL-ATMEGA328P/32877460592.html?spm=a2g0s.9042311.0.0.27424c4dVDUhoa So there has not to be any problem. Just good reading ..... :wink:

took hours to find this fix, thank you

Hello,

Just wondering if anyone more news or fixes , tips or links about the wavgat uno r3 boards? (they are not clones since they are definatly not 100% compatible)

I have 3 of those and I rather like the fact they have a 12 bit analog read resolution. The 10 bit of the regular arduino is rather crude. Specially if you use it with those bi directional current sensors. Than you only have 512 steps to devide 30 amps. (yes I will get a 20amps version) But of course I cannot read the analog values since the wavgat maxes at 3.3 volt. Also plenty of problems with a lot of libraries to get displays and other things working.

So I have them laying arround now and use nano clones which is great fun too but I rather use the wavgat since it is (suposedly) more precise and it feels like a shame to do nothing with them.

Regards,

Hans.

You would want to talk to wavgat or thier forum.
These have to be about the worst copy of an arduino available with too many issues to list.

Also posting into old threads is frowned on.

Could you take a few moments to Learn How To Use The Forum.
It will help you get the best out of the forum in the future.

Bob.