WDS network

Hello,

I would like to connect my two Yun using WDS.

On the Yun 1:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11ng'
	option path 'platform/ar933x_wmac'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option disabled '0'
	option country 'US'
	option txpower '0'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'Service'
	option wds '1'
	option network 'lan'
	option encryption 'psk'
	option key 'xxxxx'

and

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option _orig_ifname 'wlan0'
	option _orig_bridge 'true'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option gateway '192.168.10.1'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
	option metric '10'

with DHCP enabled.

On the Yun 2:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11ng'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'
        option txpower '0'
        option country 'US'

config wifi-iface
        option ssid 'Service'
        option encryption 'psk'
        option device 'radio0'
        option mode 'sta'
        option key 'xxxxx'
        option network 'wlsec'
        option wds '1'
        option server '127.0.0.1'
        option port '1812'

and

config switch 'eth0'
	option vlan0 '0 1 2 3 5*'
	option vlan1 '5'
	option vlan2 '5'
	option vlan4 '4 5'
	option enable_vlan '1'

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'wan'
	option ifname 'eth1'
	option proto 'dhcp'
	option metric '10'

config interface 'wlsec'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.10.2'
	option netmask '255.255.255.0'
	option dns '192.168.10.1'
	option gateway '192.168.10.1'

The second Yun looks to be connected to the Master AP (Yun 1) but I can’ ping it. Indeed if I add a network to the second Yun to extend my wireless network, keeping DHCP disable in this second AP, I don’t get any IP address and therefore I can’t connect.
Everything is working fine if I connect to the Master AP.

Where is the problem?