"We were not able to configure the Secure Element"

I purchased an Explore IOT Kit. It has a MKR 1010 board.
When I try to install a THING on the Arduino IOT Cloud, the board is recognized, but in the third and final step of the installation I get the message
"
We were not able to configure the Secure Element
Cannot set property '4ba3a186-3975-41ca-981e-ccbeb9b51c21' of undefined
"
I have installed Ardoino Create. I accepted "Install Arduino Create" in the Chrome settings. I can see Arduino Create Bridge running in the Task Manager processes.
I am running Windows 10 Pro.
I tried turning off Bit Defender and the installation on the MRK1010 still didn't work.
I also rebooted the computer.

Do I have a defective Arduino, or is there a fix for this?

Thanks,
Steve

I get similar message for OPLA kit using latest UBUNTU OS Seems Create Agent stops also …, I need to restart it to try again, which I did in Firefox and Chrome …

plus here is detal of screen:

{“id”:“B30rVd/5”,“code”:“bad_request”,“status”:400,“detail”:"[Ix4GEQsb] 400 invalid_request: request.wifi_fw_version must match the regexp “^(?P0|[1-9]\\d*)\\.(?P0|[1-9]\\d*)\\.(?P0|[1-9]\\d*)(?:-(?P(?:0|[1-9]\\d*|\\d*[a-zA-Z-][0-9a-zA-Z-])(?:\\.(?:0|[1-9]\\d|\\d*[a-zA-Z-][0-9a-zA-Z-]))))?(?:\\+(?P<buildmetada{“id”:“B30rVd/5”,“code”:“bad_request”,“status”:400,“detail”:”[Ix4GEQsb] 400 invalid_request: request.wifi_fw_version must match the regexp “^(?P0|[1-9]\\d*)\\.(?P0|[1-9]\\d*)\\.(?P0|[1-9]\\d*)(?:-(?P(?:0|[1-9]\\d*|\\d*[a-zA-Z-][0-9a-zA-Z-])(?:\\.(?:0|[1-9]\\d|\\d*[a-zA-Z-][0-9a-zA-Z-]))))?(?:\\+(?P[0-9a-zA-Z-]+(?:\\.[0-9a-zA-Z-]+)))?$" but got value “”, attribute: request.wifi_fw_version, value: , regexp: ^(?P0|[1-9]\d)\.(?P0|[1-9]\d*)\.(?P0|[1-9]\d*)(?:-(?P(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-])(?:\.(?:0|[1-9]\d|\d*[a-zA-Z-][0-9a-zA-Z-]))))?(?:\+(?P[0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)))?$"}Are you sure you have an Arduino board connected to your computer? Try disconnecting and connecting it again. Make sure plugin is running or restarting it. Do you see at least the power LED on your device lighting up?ta>[0-9a-zA-Z-]+(?:\\.[0-9a-zA-Z-]+)))?$” but got value “”, attribute: request.wifi_fw_version, value: , regexp: ^(?P0|[1-9]\d*)\.(?P0|[1-9]\d*)\.(?P0|[1-9]\d*)(?:-(?P(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-])(?:\.(?:0|[1-9]\d|\d*[a-zA-Z-][0-9a-zA-Z-]))))?(?:\+(?P[0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?$"}Are you sure you have an Arduino board connected to your computer? Try disconnecting and connecting it again. Make sure plugin is running or restarting it. Do you see at least the power LED on your device lighting up?

Ok, new device successfully installed for OPLA. Switched to Mac computer using Chrome. With debug on in create add-in. Worked. Problems may also be due to my viasat internet.

**What I don't know: **

  • Why am I still getting the following error message 'Cannot set property 'f1e06314-f71e-49e3-b020-dc64e1e4d993' of undefined'
  • Sometimes the Arduino IoT Cloud will recognize my MKR 1010, sometimes it wont

What I know/tried:

  • Updated my macbook air from 10.14 to Big Sur -> no chg
  • Removed any other peripherals (e.g. mouse) -> no chg
  • Deleted and installed the Arduino Create plugin 3x -> no chg

Do I have a defective product or am I missing something?

I'm excited to make the inventory tracker and I understand I must be patient & hardware is HARD AF MANE!

I am having the same issue. I have an Arduino MKR WiFI 1010. When trying to configure in iot Cloud, it gets to step 3 and throws an error:

"We were not able to configure the Secure Element
Cannot set property 'bb2d3539-ce18-4710-bea6-69d62f375cc2' of undefined

I've updated the firmware on the board to the latest "NINA firmware (1.3.0)(Arduino MKR WiFi 1010, Arduino NANO 33 IoT).

1 Like