Web Editor: "Error uploading, check if the selected port is currently available"

Hey, im on windows 7 using the arduino web editor. I am trying to upload a sketch onto an arduino micro but I always get the message

Error uploading, check if the selected board is currently available

I also cant upload a unedited new sketch, i always get the same error. In the editor, next to the board selector, there is a red cross next to Arduino/ Genuino Micro. I followed the setup of the online editor, downloaded the Create Agent and also installed all drivers that the software requested. Pls help, thank you

the green LED is flashing, the Blue one is constantly on … resetting via reset button doesnt change a thing

OK lets start with some much needed information.

We Know you have windows 7 (which one Home, Pro etc) ?

Which browser are you currently using (chrome, explorer etc.) ?

Do you have the create bridge ICON on your lower right task bar ?

When you say you installed all the drivers do you mean for the board or anything the CREATE installation offered including the CERTIFICATE as that is VITAL to the whole thing ?

Including a pic of the ICON you need to be able to see.

Debug Console usage.jpg

The icon is the Arduino LOGO one.

However That pic also shows you how to call up the DEBUG CONSOLE if we need any additional information.

EDIT
If you are unsure about anything there is a nice tutorial HERE

{"Version" : "1.1.64"} {"Commands" : ["list", "open [portName] [baud] [bufferAlgorithm (optional)]", "send [portName] [cmd]", "sendnobuf [portName] [cmd]", "close [portName]", "bufferalgorithms", "baudrates", "restart", "exit", "program [portName] [board:name] [$path/to/filename/without/extension]", "programfromurl [portName] [board:name] [urlToHexFile]"]} {"Hostname" : "UTKARSH-PC"} {"OS" : "windows"} list { "Ports": [], "Network": false } { "Ports": [], "Network": true }

@utkarshsingh

Not sure what you are trying to say ?

Does something not work ? Please add additional information after reading THIS POST

Opened port, but still doesn't work.

{ "Ports": [ { "Name": "COM7", "SerialNumber": "", "DeviceClass": "", "IsOpen": false, "IsPrimary": false, "Baud": 0, "BufferAlgorithm": "", "Ver": "1.1.64", "NetworkPort": false, "VendorID": "0x1A86", "ProductID": "0x7523" } ], "Network": false } { "Ports": [], "Network": true } open com7 9600 time="2018-04-04T23:00:03+02:00" level=info msg="Inside spHandler" time="2018-04-04T23:00:03+02:00" level=info msg="Opening serial port com7 at 9600 baud" time="2018-04-04T23:00:03+02:00" level=info msg="Just tried to open port" time="2018-04-04T23:00:03+02:00" level=info msg="Opened port successfully" time="2018-04-04T23:00:03+02:00" level=info msg="Initting default buffer flow (which means no buffering)" {"Cmd":"Open","Desc":"Got register/open on port.","Port":"com7","Baud":9600,"BufferType":""} { "Ports": [ { "Name": "COM7", "SerialNumber": "", "DeviceClass": "", "IsOpen": true, "IsPrimary": false, "Baud": 9600, "BufferAlgorithm": "", "Ver": "1.1.64", "NetworkPort": false, "VendorID": "0x1A86", "ProductID": "0x7523" } ], "Network": false }

@eborzi

What do you mean by "Opened port"

Also need much more info so please read this post first.

My problem was solved by installing driver for arduino uno in the device manager(windows 7) which is presented in the arduino create plugin folder

What do you mean plugin folder?