Web editor plugins were not installed properly in fedora 25

:frowning: :frowning: :frowning: :frowning: :frowning: :frowning:
please help me, how to install web editor plugins on fedora 25.

when I download and install related plugins, then gen some error as follows

" Problem running post-install step. Installation may not complete correctly
Error running /home/thisara/ArduinoCreateAgent-1.1/Arduino_Create_Bridge -generateCert=true: /home/thisara/ArduinoCreateAgent-1.1/Arduino_Create_Bridge: error while loading shared libraries: libappindicator3.so.1: cannot open shared object file: No such file or directory "

I’ve attached screen shot below

please someone help me to fix this.

Thanks.
Thisara

Hi Thisaa,
the agent tray icon needs libappindicator3 shared library available in the system. It is normally provided by Gnome/KDE desktop but it looks like it's not true on fedora.

Simply install it with

sudo yum install libappindicator-gtk3

and the agent should run correctly