Web radio failed afterworking for a time

After installing software (not mine as I am a nube) onto a esp32 with vs1053 dac and ssd1306 display it worked iniately fine powered from my computer via usb socket.
Then I transferred itto my 5v phone charger psu and it failed to boot up.
Connected it back to computer and still no go,tried to reload the sketch againand got an error message.
Then I tried the blink,wifi scan and hello sketches and all worked,so I conclude the hardware all work.
This is the error message code I get. Sketch for web radio is attached


ets Jun  8 2016 00:22:57

rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)

configsip: 0, SPIWP:0xee


mode:DIO, clock div:1





entry 0x400806ac

..WiFi connected

IP address:

Guru Meditation Error: Core  1 panic'ed (LoadProhibited). Exception was unhandled.

Core 1 register dump:

PC      : 0x400014fd  PS      : 0x00060430  A0      : 0x800d5811  A1      : 0x3ffb1ea0  

A2      : 0x00000050  A3      : 0x0000004c  A4      : 0x000000ff  A5      : 0x0000ff00  

A6      : 0x00ff0000  A7      : 0xff000000  A8      : 0x00000000  A9      : 0x3ffb1e70  

A10     : 0x3ffb1f5c  A11     : 0x00000000  A12     : 0x00000009  A13     : 0x3ffb1f4a  

A14     : 0x00000039  A15     : 0x00000000  SAR     : 0x00000010  EXCCAUSE: 0x0000001c  

EXCVADDR: 0x00000050  LBEG    : 0x400014fd  LEND    : 0x4000150d  LCOUNT  : 0xffffffff  

Backtrace: 0x400014fd:0x3ffb1ea0 0x400d580e:0x3ffb1eb0 0x400d14c6:0x3ffb1ed0 0x400d5a87:0x3ffb1fb0 0x4008954d:0x3ffb1fd0

simple_esp32_radio_8stns_plusrtevol.ino (7.51 KB)

Did that sketch compile ?

You have for example this:

void loop()
  if (client.available() > 0)
    uint8_t bytesread = client.read(mp3buff, 32);
    player.playChunk(mp3buff, bytesread);

if (digitalRead(voldown) == 0 && x == true)   // reduce volume
  x = false;

Press Ctrl+T in the Arduino IDE and then make the text of your sketch look good. Put every comma, every space, every indent, every new line at the right place. How can a sketch work well when the text of the code is a mess ?

It sounds like a hardware problem. If you post your schematic, not a frizzy drawing along with your code neatened up we can help. as a SWAG I think you blew some of your hardware.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.