Web Server well structured on Arduino UNO

Hello all,

Can anybody please confirm if the webserver sketch (the second extended one at http://playground.arduino.cc/Code/WebServer) works on UNO or not ?

For me it is loaded successfuly to board but does not work. Board does not even answer to ping. I see that it receives the ICMP packets (Rx led is blinking when sending ping), but does not answer. I just want to be sure that my device is ok.

thanks for answers, liptaka

What is the output to the serial monitor ? A few hours earlier someone on the forum had the W5200 chip, instead of the W5100 chip, and he had to update the Ethernet library.

Simple client test code you can try to see if your network setup is working.

//zoomkat 11-04-13
//simple client test
//for use with IDE 1.0.1
//with DNS, DHCP, and Host
//open serial monitor and send an e to test client GET
//for use with W5100 based ethernet shields
//remove SD card if inserted
//data from myIP server captured in readString 

#include <SPI.h>
#include <Ethernet.h>
String readString;

byte mac[] = { 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED }; //physical mac address

char serverName[] = "checkip.dyndns.com"; // myIP server test web page server
EthernetClient client;

//////////////////////

void setup(){

  if (Ethernet.begin(mac) == 0) {
    Serial.println("Failed to configure Ethernet using DHCP");
    // no point in carrying on, so do nothing forevermore:
    while(true);
  }

  Serial.begin(9600); 
  Serial.println("client readString test 11/04/13"); // so I can keep track of what is loaded
  Serial.println("Send an e in serial monitor to test"); // what to do to test
  Serial.println();
}

void loop(){
  // check for serial input
  if (Serial.available() > 0) //if something in serial buffer
  {
    byte inChar; // sets inChar as a byte
    inChar = Serial.read(); //gets byte from buffer
    if(inChar == 'e') // checks to see byte is an e
    {
      sendGET(); // call sendGET function below when byte is an e
    }
  }  
} 

//////////////////////////

void sendGET() //client function to send/receive GET request data.
{
  if (client.connect(serverName, 80)) {  //starts client connection, checks for connection
    Serial.println("connected");
    client.println("GET / HTTP/1.1"); //download text
    client.println("Host: checkip.dyndns.com");
    client.println("Connection: close");  //close 1.1 persistent connection  
    client.println(); //end of get request
  } 
  else {
    Serial.println("connection failed"); //error message if no client connect
    Serial.println();
  }

  while(client.connected() && !client.available()) delay(1); //waits for data
  while (client.connected() || client.available()) { //connected or data available
    char c = client.read(); //gets byte from ethernet buffer
    readString += c; //places captured byte in readString
  }

  //Serial.println();
  client.stop(); //stop client
  Serial.println("client disconnected.");
  Serial.println("Data from server captured in readString:");
  Serial.println();
  Serial.print(readString); //prints readString to serial monitor 
  Serial.println();  
  Serial.println();
  Serial.println("End of readString");
  Serial.println("==================");
  Serial.println();
  readString=""; //clear readString variable

}

ah my bad... I just recognised that in the code it used DHCP and not the defined static IP based on this: #define USE_DHCP_FOR_IP_ADDRESS.

After removing it, PING started to work. The webserver still does not send anything but maybe it is due to some other config settings, I need to check it. Currently it only prints to serial: "URI:/" If somebody already tried and could share some experience that would be nice.

Also I run the above network test client and it works ok, successfuly retrieves data from checkip.dyndns.com.

thanks again,