Website access

Anyone having trouble accessing the download area?

Yes, same here. The Arduino web team is aware of the situation and is working on getting it fixed right now.

Does it stop you opening the IDE? Mine keeps crashing.

The downloads page is back up for me now, but with the way the web works, that may not be so for people in other geographic areas.

windoze_killa:
Does it stop you opening the IDE? Mine keeps crashing.

No, I'm not having problems like that.

Which version of the Arduino IDE are you using?

Which operating system?

1.8.13 on Linux. Everytime I try running it it just closes. maybe it is trying to check for updates and crashes when it can't connect.a

1.8.13 on Linux is working fine for me.

Please do this:

  • Start a terminal in the Arduino IDE installation folder
  • Type
./arduino
  • Press Enter.
  • Wait for the Arduino IDE to finish starting, or failing to start.
  • Switch back to the terminal window if the Arduino IDE window took the focus.
  • Click and drag the mouse to select all the output in the terminal window.
  • Press Ctrl + c. This will copy the selected text to the clipboard.
  • In this Arduino forum thread, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply, making it easier for us to read.
  • Press Ctrl + V. This will paste the output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.
  • Click the “Post” button.

Hopefully that will give us some information we can use to help you with the problem.

Do you know where the install dir is?

Did you install it using the download from the “Software” page of this website?

If so, it will be wherever you extracted the downloaded .tar.xz file to.

No. I installed it using the Ubuntu software installer. It doesn't tell you the location, it just goes off and does its own thing.

This is the error it came up with.

ln: failed to create symbolic link '/home/jason/snap/arduino/41/.config/gtk-2.0/gtkfilechooser.ini': File exists
Picked up JAVA_TOOL_OPTIONS: 
Set log4j store directory /home/jason/snap/arduino/41/.arduino15
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by processing.app.linux.GTKLookAndFeelFixer (file:/snap/arduino/41/lib/arduino-core.jar) to field com.sun.java.swing.plaf.gtk.GTKLookAndFeel.styleFactory
WARNING: Please consider reporting this to the maintainers of processing.app.linux.GTKLookAndFeelFixer
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
WARNING: Error loading hardware folder /home/jason/snap/arduino/current/Arduino/hardware/jtag2updi_bak
  No valid hardware definitions found in folder jtag2updi_bak.
2020-11-05T01:38:54.527Z INFO c.a.u.n.HttpConnectionManager:153 [cc.arduino.packages.discoverers.serial.SerialDiscovery] Connect to https://builder.arduino.cc/builder/v1/boards/0x1A86/0x7523, method=GET, request id=74295C9911BF4990
2020-11-05T01:38:55.956Z INFO c.a.u.n.HttpConnectionManager:157 [cc.arduino.packages.discoverers.serial.SerialDiscovery] Request complete URL="https://builder.arduino.cc/builder/v1/boards/0x1A86/0x7523", method=GET, response code=404, request id=74295C9911BF4990, headers={null=[HTTP/1.1 404 Not Found], Cache-Control=[no-cache, no-store, must-revalidate], Server=[nginx], Connection=[keep-alive], Vary=[Origin], Pragma=[no-cache], Expires=[0], Content-Length=[0], Date=[Thu, 05 Nov 2020 01:38:55 GMT]}
2020-11-05T01:38:55.957Z WARN p.a.h.BoardCloudResolver:64 [cc.arduino.packages.discoverers.serial.SerialDiscovery] Fail to get the Vid Pid information from the builder response code=404
Could not createInput() for /home/jason/snap/arduino/current/Arduino/Wondatre_test/Wondatre_test.ino
java.io.FileNotFoundException: /home/jason/snap/arduino/current/Arduino/Wondatre_test/Wondatre_test.ino (Permission denied)
	at java.base/java.io.FileInputStream.open0(Native Method)
	at java.base/java.io.FileInputStream.open(FileInputStream.java:219)
	at java.base/java.io.FileInputStream.<init>(FileInputStream.java:157)
	at processing.app.legacy.PApplet.createInput(PApplet.java:568)
	at processing.app.legacy.PApplet.loadStrings(PApplet.java:233)
	at processing.app.BaseNoGui.loadFile(BaseNoGui.java:618)
	at processing.app.SketchFile.load(SketchFile.java:256)
	at processing.app.EditorTab.<init>(EditorTab.java:98)
	at processing.app.Editor.addTab(Editor.java:1546)
	at processing.app.Editor.createTabs(Editor.java:1519)
	at processing.app.Editor.handleOpenInternal(Editor.java:1827)
	at processing.app.Editor.<init>(Editor.java:379)
	at processing.app.Base.handleOpen(Base.java:889)
	at processing.app.Base.restoreSketches(Base.java:559)
	at processing.app.Base.<init>(Base.java:494)
	at processing.app.Base.main(Base.java:150)
java.io.IOException
java.lang.IndexOutOfBoundsException: Index 0 out of bounds for length 0
	at java.base/jdk.internal.util.Preconditions.outOfBounds(Preconditions.java:64)
	at java.base/jdk.internal.util.Preconditions.outOfBoundsCheckIndex(Preconditions.java:70)
	at java.base/jdk.internal.util.Preconditions.checkIndex(Preconditions.java:248)
	at java.base/java.util.Objects.checkIndex(Objects.java:372)
	at java.base/java.util.ArrayList.get(ArrayList.java:458)
	at processing.app.Editor.getCurrentTab(Editor.java:1422)
	at processing.app.Editor.updateUndoRedoState(Editor.java:1373)
	at processing.app.Editor.selectTab(Editor.java:1448)
	at processing.app.Editor.createTabs(Editor.java:1525)
	at processing.app.Editor.handleOpenInternal(Editor.java:1827)
	at processing.app.Editor.<init>(Editor.java:379)
	at processing.app.Base.handleOpen(Base.java:889)
	at processing.app.Base.restoreSketches(Base.java:559)
	at processing.app.Base.<init>(Base.java:494)
	at processing.app.Base.main(Base.java:150)

Problem solved.

It appears that when I opened a sketch in windows (dual boot machine) it changed the permissions on the file. Changed them back to me and all is good. I can now open it.

F@#$%^& Microsoft.

I still can't access the software download site. Are you still having probles?

I'm glad to hear you solved the issue!

Regarding the software page, it does load for me, but it takes a minute or so just to load, so definitely something is not right. I guess the web time will have more work waiting for them when they wake up this morning!

This is still happening, the attack is advanced and changing as soon as we implement mitigation. I am impressed about the capacity of bypassing some challenges. Big thanks to
@Cloudflare
for saving us again.
Arduino

@arduino
· 15h
Dear users, the http://arduino.cc website is currently under an intense DDoS attack. We are aware of the situation and dealing with it. Please bear with us while we find a solution!

Really unfortunate that people do this. I'm not in support of any type of black hat hacking, but at least some of the skillful hacks are interesting. DDoS is just so boring and mundane though, and especially stupid when targeted against a site like arduino.cc that is a resource and community in support of open source and learning and teaching.

It is probably a rival forum or micro manufacturer. :wink:

Anyone else having trouble accessing the Reference Documents? I haven't been able to get to them for a week or so. Every time I try to it sits for a while then I get "Error 522" implying that the server is blocking the request.

Not trying to hijack, I just think it's relevant to a "Website Access" thread.

I do think it has the same root cause as the issue @windoze_killa reported here.

We have a bug report in the issue tracker for what I suspect is the problem you're having:

They were kind enough to post an update with the workaround they discovered:

I believe I've discovered a fix. The links above will work if you add a slash ('/') to the end of the URL.

This works:
toInt() - Arduino Reference

but without the slash at the end it does not. It seems the broken links are the ones without the slash at the end.

Interesting.... I was able to get to the Top/Main reference page when I added it. Good to know.

This almost feels like an escaping issue. Did they apply a bad patch recently?

Hopefully, they get it fixed soon.

I think what happens is that the paths without trailing slash are always redirected to the path with the trailing slash, but for some reason that redirect is broken due to the changes the web team were forced to make to control the DDoS attack mentioned in the twitter posts I linked to above.

DDoS? Wow, I guess I missed that post. I'll go take a look.

That would also explain why the site has seemed so slow of late.

Hello, I'm Edoardo from the Operations team at Arduino. We have been subjected to a DDOS attack this week and the unfortunate consequence of it has been some pages going offline for some time. We enabled mitigations and were able to deflect part of it, but occasionally some page went offline. This happened mainly Tuesday and Wednesday.

522 is a simptom of such attack but you should not see it anymore now.

@fbody if you can link the page we'll have a look, thanks.