Weird Ardumoto Behavior

I have an Arudmoto that used to work but now it is acting sporadically. When it is set to High/High for dira and dirb, it works perfectly but when set to Low/Low, one goes the wrong way and the other does not work. This controller was working fine but now it doesn't. My other identical controller works fine. I've tried all different pins and quintuple-checked the code while experimenting with different things, but still no luck. Anyone have any thoughts? Could this behavior be caused by the lack of a pullup resistor, or does dira High or Low enalbe and disable that already?


It sounds like one of the power transistors in the chip has blown.

If you swap over the motors, is it the same channel that's faulty?

If the problem moves with the motors then its a problem with the motor.

I switched the motors, the broken channels stayed the same, so that means it’s the transistor? in what chip, the main one? L something (numbers)? lol

Thanks for your help!

Yup in the big one in the middle that gets hot.

Looking at the schematic here:

Apart from the protection diodes, the motor connections pretty much go straight out from the chip. I think your chip is blown.

But also just check you haven't got any snippings of wire or blobs of solder shorting the pins on the chip. Give the whole board a close inspection.

Save the shield for a project where you only need one motor or just want to go forwards ;)