Weird "avrdude: stk500_getsync(): not in sync: resp=0x00" error

OK I know there are a lot of these errors out there but I couldn't find any solutions for the problem I'm having, and I did google it. I have been doing some troubleshooting and think it has something to do with the software and my board not working with each other. It works fine with Arduino 0023 and I can upload my programs. However any version of arduino higher than that I get a "avrdude: stk500_getsync(): not in sync: resp=0x00" error and when I push shift it says there is no usb connected. The weird thing is when I push the serial monitor I can see the program I have loaded previously with 0023 on the arduino and interact with it.

Any thoughts? I guess ill just use 0023 for now.

Hardware and software.

windows 7 32 bit Haceduino 2009 (Decimilia clone)

I've got the same issue.Last time reinstalling the drivers worked, but now it doesnt.Try reinstalling the firmware o the atmega 16u2/ 8u2.Here is a nice complete tutorial for it: http://andrewmemory.wordpress.com/2011/04/14/upgrading-the-arduino-uno-8u2-using-flip/ Hope that helped...

I was thinking that the firmware was wrong or something. I’m not really familiar with all the lingo that link made no sense to me at all. Sorry for the noobness. My board doesn’t have the spot to short it out, and I’m not sure where to get the flip software the link is redirected to the front page.

I’ll add a picture of my board so maybe I could be directed in the right direction.

I finaly found the flip software here: http://www.atmel.com/tools/flip.aspx.

Also I found this:

Some ancient versions of the bootloader run at 9600 baud (instead of 19200). In order to successfully upload sketches to boards with this bootloader, you'll need to change the serial.download_rate in your preferences file to 9600.

on http://arduino.cc/en/Hacking/Bootloader?from=Main.Bootloader and I think that may be my problem. Under device manager settings the port I am using is set to 9600. I am debating on changing up the speed to 19200 in device manager or changing it down in the setting of the arduino platform and seeing if it does anything.

nope that didn't work

Ok so I figured out that I don't have a atmega 16u2/ 8u2 chip on my board I have a FT232RL... So I'm not really sure how to upgrade it and if it even can be.

Well I guess i’ll just go get a Raspberry Pi then.

Have you looked at the avrdude output. There should be an error message.

avrdude: usbdev_open(): did not find any USB device "usb"

However I know i'm on the right port and have the right arduino picked. I've tried different cables, tried uninstalling the drivers for the usb serial adapter, tried it on my linux machine, pushing the reset button right before upload during and right after, and everything else I could think of. Its weird because I can access the serial script that is on the arduino that I uploaded in 0023, so I know there isn't anything wrong with the communication, but for some reason it wont upload.

Do the Decimilia's have FT232RL instead of the atmega 16u2/ 8u2? I was thinking maybe I need a different board picked in the settings. Right now I have "Arduino Decimilia or Arduino Duemilanove w/ ATmega168" picked.

I did the loop-back test from http://forum.arduino.cc/index.php?topic=73748.0 and it worked fine.

The issue stk500_getsync(): not in sync: resp=0x00" error : I found It was the wrong Com port arduino indicated it connect through com port 1 when i check through device manager ports (com & lpt) it was actually Com port 3 so i changed it on arduino now fixed

hi guys ....

I have a similar items with my mega compatible board before, but after struggling over I have manage to take my board back in normal with changing the AUTORESET CAPACITOR 100nF

see here http://www.arvydas.co.uk/wp-content/uploads/2010/01/arduino-reset-mod.jpg or you can google it.

I think my capacitor is defective.

Just give a try and hope you can solve this issue