Weird Fast LED Issues / FastLED.cpp:132:9: error: 'yield' was not declared

Hi All, Very new to coding so please bare with me :slight_smile:

My previous UNO died, doesn’t respond to a loop test.

New board

BN: Unknown board
VID: 1A86
PID: 7523
SN: Upload any sketch to obtain it

I obtained the drivers and can successfully upload the Blink Sketch. When I go to upload my Fastled related stuff I get this error:

Warning: platform.txt from core ‘Arduino AVR Boards’ contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} “{build.path}/{archive_file}” “{object_file}”, automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} “{archive_file_path}” “{object_file}”. Consider upgrading this core.
In file included from D:\I\Arduino projects\Arduino Backup\USETHISFORHORNS\USETHISFORHORNS.ino:1:0:

D:\I\Arduino projects\arduino-1.8.7 RUN FROM HERE\libraries\FastLED-3.1.8/FastLED.h:17:21: note: #pragma message: FastLED version 3.001.008

pragma message “FastLED version 3.001.008”

^

D:\I\Arduino projects\arduino-1.8.7 RUN FROM HERE\libraries\FastLED-3.1.8\FastLED.cpp: In member function ‘void CFastLED::delay(long unsigned int)’:

D:\I\Arduino projects\arduino-1.8.7 RUN FROM HERE\libraries\FastLED-3.1.8\FastLED.cpp:132:9: error: ‘yield’ was not declared in this scope

yield();

^

exit status 1
Error compiling for board WAVGAT UNO R3.

Quick google on the error just confused me more :frowning:

I am running Arduino 1.8.7 with FastLED-3.1.8 (Also tried the latest version, same error)

Any ideas where to start?

#include "FastLED.h"

#define NUM_LEDS 3
#define LED_PIN 6
CRGB leds[NUM_LEDS];


void setup() { 
             randomSeed(analogRead(0));
             Serial.begin(115200);
             FastLED.addLeds<WS2812, LED_PIN, GRB>(leds, NUM_LEDS);  
  
}  
void loop() 
{
  int8_t H = random(0,50); //HUE
  int8_t S = random(60,256); //SAT
  int8_t V = random(200,256); //BRIGHT
  //middle horn
  leds[1] = CHSV(H,S,V);
    FastLED.show();
  // below for edge horns to be same
  H = random(0,50); //HUE
  S = random(150,256); //SAT
  V = random(180,230); //BRIGHT
  leds[0] = CHSV(H,S,V);
  leds[2] = CHSV(H,S,V);
  FastLED.show();
  
//makes white run quicker
if ((H <= 30) && (S >= 0 && S <= 200) && (V <= 200))
{
   // white
   delay(1);
} 
else 
{
   // not white
   delay(70);
}
}

Thank you.

The problem is the WAVGAT hardware package you're using is garbage. You might look around to see if there is a newer version that you can install via Boards Manager. I remember looking into it a while back but I don't recall the details. They are using some Chinese copycat chip on that board instead of the standard ATmega328P and this makes everything much more complicated. It doesn't seem like their boards are even cheap enough to be worth the hassle.

Cheers, bought genuine and bingo bango, all worked :slight_smile: