WEIRD Problem... Mini vs UNO

I have run into the most perplexing problem. I've written a program with a variable speed control for spinning LED's at varying intensities using NeoPixel rings that uses a momentary switch to switch between the different cycle rates. When testing on the UNO platform, it works beautifully. I'm using a 10 kOhm resistor, as recommended by almost every book I've seen and forum I've read. It works like a champ! If I don't connect the momentary switch, the UNO defaults to the preset rate and doesn't cycle through the other rates.

Problem is I actually use the UNO for development only. For practical application, I move the program over to an Arduino Mini Pro. When I move the program to the Mini, (or a Nano... tried both) the program behaves completely different. Instead of defaulting to the preset cycle rate, it starts automatically cycling through the five rates I have programmed into the code. The switch does nothing. The Mini seems to act as though the momentary switch is being pressed and held. I have NO idea why they are behaving differently. Same code. Same number of LED's. Same connections. Same voltage. (I've tried it with the Mini being powered independently and with it being powered directly from the UNO/USB) I've tweaked the code here and there to no avail. I can't understand why it works perfectly on the UNO but fails on the Mini...


Post your code using the </> icon to supply code tags and we might be able to spot what you have done wrong.

Also post your schematic.

There is no reason i can think of why the Mini/Nano would behave differently to Uno. Like Mike says, post code & schematic.

I'm using a 10 kOhm resistor, as recommended by almost every book I've seen and forum I've read.


Indeed fascinating that you are using a 10 kOhm resistor.

I daresay there are many things for which you might be using a 10 kOhm resistor. Possibly even to scrape the wax out of your ear.

What would be really interesting to know is for what you are presently using it? :roll_eyes: