Weird problem with Arduino Nano Board

Hi everyone,

I encountered a weird problem with my nano. In the beginning, everything worked fine, I could use it with my Win XP machine. However, the next (or maybe the 3rd or 4th) time I plugged it back to the USB, Windows informed me that the USB device couldn’t properly be recognized and should be changed if the problem persists. Note that the blink example which I uploaded seemed to work.
Thinking of a power supply problem of the FTDI I wanted to measure the voltage between the 5V and the GND Pins. Due to my clumsiness I shorted the GND pin with the Vin pin next to it while doing this… and, oh wonder, I heard the Windows unplug and plug sounds and the Nano was properly detected and ready to use.
Funny thing is, when I unplug and plug the Nano again, the same error occurs. Even funnier, when I shortcut the GND and Vin Pin it works again. And most funny, this exactly same errors has happened/is happening to me with two different nanos.

Anyone has an idea what exactly is not properly working, if something is actually really broken or any other issue?

Many thanks in advance and a merry christmas!

Kai

Note that nanos are remakes from 2 different vendors. Not because of the few bucks I save but because I enjoy the good service at amazon (GER), where unfortunately only nano remakes are in stock.

Sounds like you have a bad FTDI function. Inspect the usb connector’s solder pads to see if anything looks cracked or burned and maybe remelt the pads. Otherwise it’s not cost effective to repair, a E-bay Asian nano can be had for < $10.

Lefty

Hi,

i checked the USB connector. Seems to be all fine. But let me ask, what happens exactly when I shortcut the Vin and the GND pin?

Thanks,

Kai

Anyone can tell me what happens when I shortcut Vin & GND, which helps to get my Arduino or maybe particularly the FTDI running again?

Thanks

I would guess multiple things might happen when you bridge VCC and GND.

  1. A Reset of the Arduino as the will be no power going to the arduino.

  2. Reset of the USB Port itself (that would depend on the USB Controller)

What error messages come up? Did you try searching the board for that error message? This or similar errors comes up a fair amount of times.

Your Arduino probably has a counterfeit FTDI chip. Windows may have updated the driver, which doesn't seem to work with the counterfeit chips. Download and install an older version of the driver, it worked for me. I bought a couple of Nanos that won't work with the latest driver, but do with the driver downgraded.

Information in this thread:
http://forum.arduino.cc/index.php?topic=198681.msg1477473#msg1477473