Wemos D1mini communication

I have been using a d1 mini R2 because of their larger memory. Everything was working great until I updated the boards using board manager to esp8266 ver.3.0.2. Now, the serial output is not comprehensible because it is mostly the utf-8 extended character set. The program is writing to the serial monitor, I just can't read it. I have tried: (1) going back to an earlier version of esp8266. (2) changing the baud rate, (3) swapping processors ,and (4) loading different sketches. Nothing works. A clue us that the blue LED on the d1 now blinks continuously. A quick search of the web did not tell me what that indicates.
Thanks for any help you can provide.

Start by posting an example of a sketch that exhibits the problem

UKHeliBob:

I have added the code for the sketch to the end of my post. Hope that helps you.

Thanks for your interest.

R

I can't see it

Do you have the baud rate set correctly in the serial monitor? Usually for an ESP the default speed is 115200.

I tried several baud rates, changing both the code and the seral monitor of course. It used to work at 9600 and I tried both high and lower. I’ll try 115200 though.

Thanks

R

[Mod edit link removed]