werid error - No device found

been working on my second Due for 8 weeks or so
suddenly i started getting No device found on COM5

i tried the Native port & can program the device -
but the programming port seems to be kaput ..
Due #1 / the nano / & others work fine ...
tried to change to COM10 no effect ..

anybody seen this before?

reply to my own post :
pretty sure the ATMEGA16U2 has lost its programming ..
what hardware is needed to reflash it ?

never mind
-- was able to dig up the info / for the record

A) avrdude.exe / avrdude.config is not located where the doc say -- it is in:

B) the hexfile is buried pretty deep

C) I used a Nano as a AVRISP which has the same pinouts as the UNO descibed in

D) the Nano would error out ("avrdude: stk500_getsync(): not in sync: resp=0x15") without the required a 120ohm resistor between Vcc & reset

--- this was all to no avail - my Due still can not be programed via the USB Programming port
to program my Due requires a tenitive connection to the USB native port which resets after every upload (^#&$%&%!!!)