what about ClearType BUG !? Why is it not getting fixed?

I use latest Arduino IDE. What about ClearType BUG !? Why is it not getting fixed?

I'm using WinXP SP3, and using "standard" is not an option as it does not work for desktop, and some other windows UI components. You can't customize it either. Other JAVA software works fine so this is clearly Arduino IDE bug, an old bug.

What are you talking about? Clear Type bug?

What is cleartype: http://www.microsoft.com/typography/ClearTypeInfo.mspx

Why is better than standard antialiashing WinXP http://www.microsoft.com/typography/cleartype/tuner/step1.aspx
Win7 http://www.howtogeek.com/howto/28790/

And yes it works on CRT fine.

Ok, but what is the "bug" you speak of? Simply that you think the IDE should use cleartype, but it doesn't?

(so: it's not getting fixed, because no one has reported a bug?

There is Anti Alias Editor Text Option Ignored [imported] · Issue #154 · arduino/Arduino · GitHub
and Editor Font Selection Capability [imported] · Issue #232 · arduino/Arduino · GitHub )

The menus are all blank, the program is not usable with Creartype enable, and without I can’t use my PC because of poor readability of text. This is on both Arduino IDE versions.

arduino_cleartype_bug.JPG

Ah; more debugging will be necessary. It works fine for me with cleartype enabled, on XP, W7, and 8.1, and it's not a problem that anyone else has reported, so it seems to be something particular to your system. You mentioned that you've been trying to manually edit preferences and themes; does it work better if you clear out all those files and start with a fresh install of Arduino?
(some of the files you'll have to delete manually, I think.)

I don't think anyone will claim that the arduino font and color choices are the most wonderful of all possible, but it should be better than "completely blank" and "unreadable."

does it work better if you clear out all those files and start with a fresh install of Arduino?

No, it was like this from the start.

I don't think anyone will claim that the arduino font and color choices are the most wonderful of all possible, but it should be better than "completely blank" and "unreadable."

yes the menus are white, blank, empty.

I downloaded v1.5.8 latest, the cleartype bug is still there, win xp32 bit sp3 here.

I haven't got WinXP any more so I can't try this out but is the info in this link any help?

Pete

el_supremo:
I haven't got WinXP any more so I can't try this out but is the info in this link any help?
Is ClearType Enabled On Your Windows XP Desktop?

Pete

Well yes I know that disabling cleartype will make the arduino IDE work. However this makes text hard to read. So I do not think this is a proper way to solve this, no other Java app has this bug on winxp (at least that I use).

I now use UECIDE as alternative to arduino IDE. But I would like to use official version too. If somebody would debug this .

This is the first I’ve ever heard of this problem, so as a quick sanity check, I fired up a virtual machine with XP and turned on ClearType.

As you can see in this screenshot, Arduino 1.0.6 seems to work find on a clean XP system with ClearType enabled. Perhaps you’ve tweaked and fiddled with many system settings on your XP install? I’m sure if you test with a clean XP system, you’ll get the same results I just did.

Hello

Smilem is right !!!. I just tested it with an old PC with Windows XP SP3 and cleartype activated. Therefore, this bug is not a problem specific of the Smilem's PC.

My nose tells me that the root of the problem must be sought in java of IDE.

Regards

Try using VirtualBox. It's free. Install Windows in a virtual machine, so you have a fresh & clean copy of Windows without all sorts of "theme" customizations. Do NOT install other software, especially things that customize Windows appearance.

I recommend configuring the virtual machine with no networking, but with a shared folder. Then it's easy to let it use files from your machine, but you don't have to worry about it getting network access and getting infected with all sorts of adware and malware.

Install only Arduino and turn on ClearType. I'm sure you'll see the same results I did. It does work properly.

Then you could start really working on this problem, by slowly duplicating your system's customizations, one by one, until you discover what changes messed up the Arduino menus.