What could damage my Arduino nano?

Yesterday evening everything worked well. Today morning I am trying to upload sketch to the Arduino (nano china, CH340) and get the following:

Writing |

avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x00

############avrdude: stk500_cmd(): programmer is out of sync

avrdude: stk500_recv(): programmer is not responding

Check wiring, settings, cable, another PC. The same result.
Took another Arduino from the same supply. Works.

What could damage my Arduino nano? Static voltage? This is the first time in 3 years of insensitive playing with Arduino. I was told that Arduino nano is quite tolerant to static voltage.

What can I do with this damaged Arduino? Is it possible to restore it?
The boards is still recognizable by PC and blinks with leds when it is connected.

Please do this:

  • (In the Arduino IDE) File > Preferences
  • Uncheck the checkbox next to “Show verbose output during: compilation”
  • Check the checkbox next to "Show verbose output during: upload
  • Click “OK”
  • Sketch > Upload
  • After the upload fails, you’ll see a button on the right side of the orange bar “Copy error messages” (or the icon that looks like two pieces of paper at the top right corner of the black console window in the Arduino Web Editor). Click that button.
  • In a forum reply here, click on the reply field.
  • Click the </> button on the forum toolbar. This will add the forum’s code tags markup to your reply.
  • Press “Ctrl + V”. This will paste the upload output between the code tags.
  • Move the cursor outside of the code tags before you add any additional text to your reply.

That’s an unusual failure! The fact that it starts indicates that nothing is seriously broken - the bootloader is intact, the chip is able to respond and do complex tasks, the serial adapter is working. Most failures would preclude such things… But in that case, why is it failing?

You don’t - by any chance - have anything else connected to pins 0, 1, or reset do you? That could cause such failures - either by the other thing trying to communicate on the serial pins while you’re trying to upload, or by resetting it mid-upload by pulsing reset.

Is anything on the chip getting warm/hot when it’s plugged in (indicative of a failed component - maybe burned out regulator or something, which in turn could be loading the supply enough to cause power supply problems).