What if your students can't even install Arduino?

There are times when your students just can't install Arduino. I'm starting this thread to share some experience and how others will share theirs.

This is a real issue. Several possible reasons: 1. Student has no access to a computer that he can install program to, possibly due to restrictions on school computers. Most of the time working with an IT tech person is a pain. Whenever they decide to wipe lab computers clean, you will be surprised they software is no longer there. 2. Student has no skill in software or hardware installation. This happened before, especially when the computer is a Mac. There are additional steps compared to installing some typical apps on mac. Even with a PC it happened before.

My possible solution is to have a computer prepared for the student. I believe most of us don't have the money to get one laptop per student. So the cheapest thing is to use a raspberry pi 2 B board. It's not too hard to set up arduino IDE and board to run on it, but most students that have computers will have laptops, so no way to locally connect rpi to their computer.

My possible solution, although not ideal:

  1. Go through a complicated process to set up RPI to be a DHCP server on its ethernet port so you can connect your computer to it via ethernet cable. This has been done before. Here is the thread with steps:

https://www.raspberrypi.org/forums/viewtopic.php?f=99&t=81165&start=25

The issue is not all laptops have ethernet ports, especially the extremely cheap and expensive ones.

  1. Go through a similarly complicated process to set up RPI to be a DHCP server on its wifi dongle so you can connect your computer to it as if it were your home wifi router. I have not been able to make this work, yet. It would pose some issues with multiple units in one classroom and hard to tell which is which.

In both cases, you can install a simple program such as mobaxterm or tightVNC to do graphical interface. That is still not plug and play. I tried the steps to use a web browser as client but that failed on my unit.

Anyone with success down this path?