what is ^CINIT result code in gsm module (A6-Ai-Thinker) ?

hi. I'm using gsm/gprs A6 module with arduino.

everything is OK and the module works perfectly.

BUT, sometimes there is a problem with it.


I have only a problem:

what is "^CINIT" result code from the module?

I searched a long time,but didnt find anything.

for example, I saved 2 contacts in SM in the module. now I want to query them.

I tested two different case :

//========== first test: //==========

when I wrote:

a6.write("AT+CPBR = 1\r")

it gives me correct result.

BUT, if I write a6.write("AT+CPBR = 2\r") after that, I give the following answer:

^CINIT: 2, 32, 41891 ...

//========== second test: //==========

when I wrote:

a6.write("AT+CPBR = 2\r")

it gives me correct result.

BUT, if I write a6.write("AT+CPBR = 1\r") after that, I give the following answer:

^CINIT: 2, 32, 41891 ...

namely, I can give only first request and the second request give me "^CINIT" result code.

why this occurred, while I'm sure that two place (1) and (2) are filled by my contacts?

thank you

Remove the spaces around the equals sign. Most AT devices I have seen/used do not like spaces in the command. The brief look I've done for A6 documentation has examples without spaces.

Pete

el_supremo: Remove the spaces around the equals sign. Most AT devices I have seen/used do not like spaces in the command. The brief look I've done for A6 documentation has examples without spaces.

Pete

Yes, of course. I used AT commands without space. the spaces here are mistyping... Now, what is "^CINIT" result code? for example: ^CINIT: 0,0,1

I have the same problem using the same GPRS chip (exactly this module ).

I was controlling it using a transistor to reduce power consumption but now it doesn't work. So I've connected it to the PC and I've sent AT commands using the AT Command Tester V28 and it responds well to the AT, ATOI and similar commands but when I send network commands, it answers this (the bold text is the introduced command):

AT+CPIN?

+CME ERROR:10

^CINIT: 1, 0, 0

^CINIT: 2, 8, 41891

^CINIT: 1, 0, 0

^CINIT: 2, 8, 41891

^CINIT: 1, 0, 0

AT+CREG

+CME ERROR:3

^CINIT: 1, 0, 0

^CINIT: 1, 0, 0

+CREG: 0

AT+COPS=?

+CME ERROR:3 Unable to find networks.

Obviously the SIM card is connected and it has no PIN code. So, what's the problem?

PinaGamer, did you ever resolve this? I seem to be having exactly the same problem with my A6.

drunnells:
PinaGamer, did you ever resolve this? I seem to be having exactly the same problem with my A6.

My problem turned out to be something simple. I had incorrectly assumed that the notched end would be inserted first (because it is keyed) with the square end sticking out the back. On the module that I have this is not the case, the square end should be inserted first - see attachment. So for me these messages turned out to be accurate, the module was unable to talk to the SIM card.

a6_sim.png

Thanks drunnells! I made the same mistake.