whats an error and whats not an error

To begin with I'm always thankful that we have forums for those of us who just don't understand. And people willing to help others.

Anyhow I've been trying to upload with Arduino the latest with Multiwii Pro 2.4 I have had all kinds of problems. Guess I'm just dumb. I first tried to use my Laptop with Windows 8.1 couldn't get anywhere with that, wasted three days pulling my hair out. So I also have another hard drive with xp on it so I decided to install it and see if I could do any good there. Well I have got so far as to start to load everything and just at the end my upload stops. I don't know if this is an error or not. At the bottom of program it says a couple of things. One is "Sketch uses 18,606 bytes (7%) of program storage space. Maximum is 253,952 bytes." The other is "Global variables use 2,627 bytes (32%) of dynamic memory leaving 5,565 bytes for local variables. Maximum is8,192.

Also get worded in red Arduino stk600v2 receive message timeout.

This being my first for anything to do with either program has me stumped I have no Idea what to do. I'm hoping someone here does.

.. and you have selected correct card and serial-port?

Thanks knut_ny

As far as I know. The board # name I got from watching a utube video. I have no idea if its correct. Also the port I know for sure is correct by checking in my device manager.

Thanks again

Hello there,

  • what is the name of the board, and what are the error messages that you receive ?
  • you are able to select the serial port, correct ?

Let's try to upload an easy program which is known to work, like Blink.
That will test the toolchain / environment.

dan

Thanks dsauriol

The board is Multiwii as sold by Hobbyking. I don't understand about toolchain or Blink. Can you explain please. Errors if that's what they are, are in my Post.

If you load the IDE and follow the menu sequence:

File --> Examples --> Basics --> Blink

the IDE will load the Blink example. Can you compile and load that program onto your Arduino and run it. It should blink the LED on your board at 1 second intervals.

Thanks econjack

My board does blink when I am loading software.

Time to post your code. Please be sure to read Nick Gammon’s guidelines at the top of this Forum for posting here, making sure to use the code tags ("</>") for the source code.

Sorry econjack

I have read it but I don't understand it at all.

Sorry but this surely is not my gift from the LORD.

  1. Put your program code that you are working on into the Arduino IDE.
  2. Press Ctrl-T to format the code in a standard format
  3. With the cursor in the IDE source code window, press Ctrl-A. This highlights the code
  4. Press Ctrl-C. This copies the highlighted code to the copy buffer.

Now, go to this Forum, and

  1. Click on the Reply button.
  2. Click on the code tag icon, “</>”, just above the first “smiley face” where you write your reply. You will see [code ][ /code] appear, with the cursor blinking in between the two.
  3. Press Ctrl-V, which will copy your program code from the copy buffer into the code tag space.
  4. Click Post, which will allow us to look at your code.

Which MultiWii do you have?

Take a look at the biggest chip on the board, and see what it says - that will tell you what chip it uses, and thus which board to select (assuming it behaves like the comparable arduino, which it hopefully does)
If it's '328p, try saying it's an Uno. If it's a '2560, a mega, 32u4, leo.

Drazzy thanks

Ill answer you first because I have an answer.It says ATMERA 2560 then 1611 1420

Thanks again econjack

My program is Multiwii 2.4 where do I find the code for it ?

My program is Multiwii 2.4 where do I find the code for it ?

What? In your first post you said:

I've been trying to upload with Arduino the latest with Multiwii Pro 2.4

If you don't have the program source code, what have you been trying to load into the Arduino IDE??

econjack sorry

when I hit Ctrl-T I get a reply in the lower blue strip says (No changes necessary for Auto Format)

By the way Im back at trying the upload on windows 8.1

Thanks

v

I had problems with my laptop but I think I'm ok now so ill stay with Windows xp. Sorry for all this.

Well I thought I had my problem solved with my other laptop but I guess not so I will be staying with windows 8.1 I give up on xp.

Got a few replies but nothing that helped. Never did answer my question what is an error. Oh well there are others out there willing to help. Thanks to all who tried.

Thanks again

have a blessed day

strightclaw:
Got a few replies but nothing that helped. Never did answer my question what is an error. Oh well there are others out there willing to help. Thanks to all who tried.

Thanks again

have a blessed day

"Sketch uses 18,606 bytes (7%) of program storage space. Maximum is 253,952 bytes." The other is "Global variables use 2,627 bytes (32%) of dynamic memory leaving 5,565 bytes for local variables. Maximum is8,192.

means your sketch was successfully compiled. A message not an error.

Also get worded in red Arduino stk600v2 receive message timeout.

Also mean exactly what it says, the board timed out when it tried to upload. This usually means you have the wrong board or the wrong port selected.