When I change sketch version to 1.5.x from 1.0.x, I get compile error message

When I upgrade sketch version to 1.5.x, I get compile error message as below.

error: variable ‘debug_receiving_data_table’ must be const in order to be put into read-only section by means of ‘attribute((progmem))’ error: variable ‘noti_string_table’ must be const in order to be put into read-only section by means of ‘attribute((progmem))’ error: variable ‘at_cmd_table’ must be const in order to be put into read-only section by means of ‘attribute((progmem))’

const char at_command_wset[]                PROGMEM = "AT+WSET=0,%s";
const char at_command_wsec[]                PROGMEM = "AT+WSEC=0,%s,%s";
const char at_command_wnet[]                PROGMEM = "AT+WNET=1";
const char at_command_wjoin[]               PROGMEM = "AT+WJOIN";
const char at_command_wstat[]               PROGMEM = "AT+WSTAT";
const char at_command_scon_tcp_client[]      PROGMEM = "AT+SCON=O,TCN,%s,%d,,%d";
const char at_command_scon_tcp_server[]     PROGMEM = "AT+SCON=O,TSN,,,%d,%d";
const char at_command_scon_udp[]            PROGMEM = "AT+SCON=O,UCN,%s,%d,%d,%d";
const char at_command_fdns[]                PROGMEM = "AT+FDNS=%s,%d";
const char at_command_fwebs_down[]      PROGMEM = "AT+FWEBS=0";
const char at_command_fwebs_up[]            PROGMEM = "AT+FWEBS=1,A";
const char at_command_smgmt[]           PROGMEM = "AT+SMGMT=%c";
const char at_command_ssend[]               PROGMEM = "AT+SSEND=%c,%s,%d,%d";
const char at_command_ssend_data[]      PROGMEM = "";
const char at_command_wleave[]          PROGMEM = "AT+WLEAVE";

PROGMEM const char *at_cmd_table[] =
{
        at_command_wset,                    // AT_WSET
        at_command_wsec,                    // AT_WSEC
        at_command_wnet,                    // AT_WNET
        at_command_wjoin,                   // AT_WJOIN
        at_command_wstat,                   // AT_WSTAT
        at_command_scon_tcp_client,     // AT_SCON_TCP_CLIENT
        at_command_scon_tcp_server,     // AT_SCON_TCP_SERVER
        at_command_scon_udp,                // AT_SCON_UDP
        at_command_fdns,                    // AT_FDNS
        at_command_fwebs_down,          // AT_FWEBS_DOWN
        at_command_fwebs_up,                // AT_FWEBS_UP
        at_command_smgmt,               // AT_SMGMT
        at_command_ssend,                   // AT_SSEND
        at_command_ssend_data,          // AT_SSEND_DATA
        at_command_wleave               // AT_WLEAVE
};

// Read Point
strcpy_P((char *)tmpstr, (char*)pgm_read_word(&(at_cmd_table[AT_WNET])));

I think that it occur due to upgrade version of avr-lib. But I don't know how to solve this compile error message. please help me.

Change:

PROGMEM const char *at_cmd_table[] =

to:

const char * const at_cmd_table[] PROGMEM =

Hi Nick

Thank you for your reply. I solved this proble due to your help. Thank you very much.