Where is my order?????

I placed an order on April 23th ORDER #400000607 and it hasn't been shipped! Customer service is nonexistent. I've sent at least 10 e-mails and not a single reply.
Terrible experience with this company. >:(

Sorry to hear that.

Did you try to contact store support via this form:
https://store.arduino.cc/store-support

Did you check to be sure their responses didn’t end up in your junk mail folder?

I have e-mailed several times support@arduino.cc, store-edu@arduino.cc, admin.it@arduino.cc, and nothing

I ordered an Arduino CTC 101 Program - FULL. I paid by credit card. The status of the order is still processing.

I will have to charge back if I don't get an answer today.

I am so disappointed.

I understand your disappointment - I would be furious if it happened to me.

However you must understand that this Forum is not connected with the Arduino store. We are just volunteers who try to help people who are having difficulty getting their Arduino projects to work.

...R

That does seem quite frustrating considering a major part of what you're paying thousands of dollars for with the CTC 101 kit is support.

But I have to wonder, did you completely ignore my last reply?

I did reply to you, I used all the possible ways to contact them and this forum is my last resource.

No, you didn't reply to me. I asked:

pert:
Did you try to contact store support via this form:
Arduino Official Store | Boards Shields Kits Accessories

Did you check to be sure their responses didn't end up in your junk mail folder?

You responded:

johannag:
I have e-mailed several times support@arduino.cc, store-edu@arduino.cc, admin.it@arduino.cc, and nothing

In no way did that answer either of my questions, unless by not answering my questions you meant to imply that you did neither of those things.

Did you try to contact store support via this form:

Did you check to be sure their responses didn't end up in your junk mail folder?

Yes!!!! when I click Arduino Official Store | Boards Shields Kits Accessories

It takes me to the website again, that's it. I don't see any contact form there.

and I don't have any messages in my junk folder

That’s odd. I get a contact form:
Clipboard02.png

when I click on https://store.arduino.cc/store-support this is what I see

This is your image:
432407f1b99418c0c59d449aab1658bc685163f6.jpg

It seems like you are being redirected to some USA site, where i am lead to an European site (as i am from Europe and i can guess so are pert and Robin2).
I do see the form there.

To the right top corner of your screen, a so called geo locator icon is visible: .
It is second one from the right and i copied the picture into this post, but it’s probably invisible to you as the color of it is very close to the background color of the forum.
You might want to try to set your location to Europe and see if that takes you any further.
While sending your message, point to this thread, as the shop people seldom see this forum.
This is the link to this thread:

forum.arduino.cc/index.php?topic=547965.msg1935520

If there is an option to rescind your credit or debit card payment then that is what I would do. And buy the thing from someone with good after sales service.

Sorry, I have a very short mail-order fuse. One week is too long. I might put up with two weeks if the price was really good or the thing was very unusual.

...R

I'm actually in the US. I just happened to have my location set to Europe / Africa in the Arduino Store. I have to check product pages for both locations when I'm requesting documentation fixes because there's this perpetual problem with getting the changes pushed to the product pages for both locations.

When I set my location to America/Asia/Oceania I just get redirected from http://store.arduino.cc/store-support to Arduino Official Store | Boards Shields Kits Accessories — Arduino Online Shop, which has the exact same form as my previous screenshot.

Maybe something is going wrong with the redirect for johannag. Please try going directly to:

I don't mean to minimize the problem of emails to official email addresses not being returned in a timely manner.

If I were an educator I would lean towards buying a bunch of Nanos, breadboards, jumper wires, and components with that $2000 and making my own way with the curriculum. I feel that the AVR boards (Uno, Nano, Mega, Leonardo, etc.) would be a better introduction to Arduino than the Arduino 101. However, I'm sure CTC 101 is a great program and the important part is to give the students the opportunity to work with Arduino, via whatever path works best for the educator.

I should mention that, although MAS3 is absolutely correct about the Arduino forum in general not being read by anyone from Arduino, the
Education and Teaching forum section seems to be closely monitored by the Arduino team. If you post there you should get an official response within a couple days. Since this is an issue with a purchase from the store and not even really an education issue yet, it's reasonable to try to contact Store Support since that will be their area of expertise but a member of the Arduino Education team should also be able to connect you to the people running the store.

johannag:
I have e-mailed several times support@arduino.cc, store-edu@arduino.cc, admin.it@arduino.cc, and nothing

I ordered an Arduino CTC 101 Program - FULL. I paid by credit card. The status of the order is still processing.

I will have to charge back if I don't get an answer today.

I am so disappointed.

Hello,

We are sorry that you had to experience such issues with this? Was your case addressed eventually?

Best regards,

Hey that is interesting and very rare. I once considered buying products from the Arduino site. I first tested how responsive the store was to contacts made through the website and through email, and found it was not adequate. I was unable to get responses from the store in a timely manner, so I resolved to just buy elsewhere. In the past getting responses was pretty much not going to happen. Perhaps that can change.

Hi Valentina!

It's good to see you, an official rep from Arduino, here on the forum. You must realize however, that your response, five months later, illustrates the problem.