White Screen after Program Upload

Hello All,

I have done something to my Esplora board (with TFT display) and i am not sure how to 'un-do' it. I have loaded several example programs (Blink, Pong, etc) with no issue. Everything was working fine.

I wrote some code for a new program (using the Eclipse IDE for Arduino) and tried to upload it from there. I got an error from AVRDude saying that no programmer was set.

I decided to go back to the Arduino IDE and just upload from there, since that was how i had successfully uploaded other programs.

When i uploaded mine, all i see is a white screen on the TFT display.

Worse, when i upload example programs, the white screen just stays there - the example programs don't seem to be doing anything.

I have unplugged the display from the board and tried to upload the simple blink example, but the LED doesnt blink.

It seems like i have thrown the board into some weird state where it will accept the program upload, but nothing happens after that.

Has anyone run into this before?

Kind Regards, brian

You can't really throw the board into a "state". Have you been plugging external things into it? Are you saying the upload works fine, but the TFT display shows nothing?