Whooops. What now?

OK, a particularly bad attempt at desoldering appears to have lost me a soldering pad... on a board I still want to use. I've soldered the replacement component in place but, lacking the pad, it isn't flowing well, and there's no continuity between this component and the pin which ought control it.

Is there a magical way to flow into a hole with no pad or should I run some revision wire?

should I run some revision wire?

I would do that. You can get adhesive copper tape from many hobby shops that you could attempt to replace the pad with but it is tricky and probably not worth it. Just use a bit of thin wire. I would use verowire:- http://freespace.virgin.net/john.hardaker/Musatek/vero.html

Hey, we've all been there!

I have a GPS unit I was trying to solder some wires onto so I can bring out some headers for my Arduino... but I melted the pad completely off.. and it's not a through-hole board.. so I really am lost on what to do! (other than hook it up to my computer VIA usb and send data over.. but that's not fun!)

Again use verowire, tin the end in a blob of solder on your iron tip. Then just touch the iron on the chip leg. You can directly solder it on. For some pictures of stuff I have made using this wire see:- http://www.thebox.myzen.co.uk/Hardware/Econo_Monome.html

http://picasaweb.google.com/jmcglo13/ArduinoVSGPS?feat=directlink

If you look at the first picture, and zoom in, you'll see my problem. :/

I tried soldering to TXA, which is below RESET.. lol without much luck! :)

I believe it's a 4 layer board, and I believe the serial connection is coming from under the GPS unit. There is another TX and RX, but they trace back to the ATMEL MEGA16L. I wasn't able to pick anything up from those.. I tried every baud rate I could think of, but nothing. I'm guessing they're for programming/debugging, but /shrug.

The device shows up as "GPS USB Serial Interface Driver" if that helps me any.. :X