Why Bluetooth distance is shortened MULTI DROP

Hello. I'm planning a Bluetooth communication PCB.

Last month, I purchased 3-4 prototypes of Bluetooth modules for PCBs.

The Bluetooth module is SPP Bluetooth version 2.0 specification. I bought a dipole antenna together.

According to the company's explanation, the communication distance is about 1km. To make a PCB that I'm planning,

Since we needed a 2:1 connection, we are testing whether the connection is good and communication is good by (multi-drop).

As shown below, two USB modules provided by us and a test socket made by me were connected to each board of Arduino Nano, Uno, and Mega through a breadboard as if HC06 were connected.


On the left is the test board provided by us. It operates when power is applied to the USB/interface or the soldering area at the bottom. The right side is the test socket that I made. Orange and yellow are 3v3 power. (* According to the manufac's explanation, if you don't use the test board, you should apply 3.3v power to both vcc and pvcc lines. That's why there are a total of 5 strands of vcc, pvcc, rx, tx, and gnd for minimal communication. During the test, 4.7uf 16v tantalum capacitor was used ( on the breadboard).

The communication distance is inside the 74m2 building. Of course, communication also works properly with rx and tx.

Problems that have occurred:

After maintaining a 2:1 connection for about a week, I tried to remove one of the two slabs among the three modules.

And I connected the removed slave module back to its original state. However, only the modules that have been removed from the time of connection are not paired. Automatic reconnection is on. Basically. This phenomenon has been repeated about three times a month.

Some of the measures I've taken:

Initialize all modules and reset again =

It's not resolved.

Buy another master module and change the master = solved. But symptoms repeat after a week.

Bluetooth module power source changed =

Initially, Bluetooth power supply was set as Arduino 3VOUT, and as shown in the figure below, after configuring a 3.3v voltage circuit with a 5v cell phone charging adapter->non-isolated converter sr 1-233, 3.3vdc is applied to the bluetooth module.


chipsenbcd1x0_usbtb: test board and Bluetooth module

tsr 1-2433 : 5vdc to 3.3vdc non-isolated converter

Power source: 220vac to 5vdc Cell phone charging adapter

What I found out after a certain amount of time:

I'll buy the same new Bluetooth module, set it to Master,

We tested again, and the same symptoms appeared a week later. It turns out that the pairing of the module proceeds normally.

It turns out that the connection is not bad, but when Bluetooth modules are connected 2:1 automatically, one of the slave modules rapidly shortens the connection distance (from 50m to 1m).

At the time of purchase, it was a module that was paired all over the 74m2 building. However, after maintaining the connection for about a week (often when the power was removed and re-applied), one of the two slave modules has drastically shortened the access distance from some time on.

If you take one of the three modules from some point and plug it in, this problem always occurs. This problem occurs in the test socket I made and on the usb test board.

It's only connected within 1m. The other one is okay.

I think the master module part is something wrong. If you replace the master module with a new one, all problems will temporarily disappear.

However, the master module with the previous problem cannot be used as the master again. The same problem happens again. However, it could be used as a slave.

The headquarters says they don't know what the problem is. Samsung is also using its products, so we have some confidence in the products.

I attached a Bluetooth module manual and a data sheet link below.

​https://www.lemosint.com/wp-content/uploads/2018/12/ds_parani-bcd110_v1.0.0.pdf

Please advise what the problem is that the connection distance is shortened at some point when automatically reconnecting after the 2:1 connected BL module was first paired.