Why did my Arduino Nano burn out?

I have had an Arduino Nano for a project I was building, but suddenly it burnt out and would not upload sketch anymore.

I tried it with an Arduino Nano clone from China, which also burned out within 10 minutes. I have absolutely NO idea what happened and why...

Dear fellow troubleshooting detectives, please help me find the method these Arduinos were brutally executed.

The project included following components:
1 x 5V relay for Arduino (regular cheap type sold everywhere)
1 x RC522 RFID card reader module
1 x Arduino Nano (real)
1 x Arduino Nano (clone)
1 x Arduino Nano Screw Terminal
1 x 12V solenoid spring lock (springs open when 1 second pulse 12v are applied)

Wired like this:

Arduno Nano put inside Screw Terminal adapter, which was screwed onto a wooden plate. The RC522 was hooked up to the Arduino the following way. Dupont cables were screwed into the screw terminals to keep them tight.

522 Wiring(RC522 left, arduino right):
SDA-10,
SCK-13,
MOSI-12,
MISO-11,
GND-GND,
VCC-3.3V,
RST-D5

Relay:
GND - GND on Arduino
V - 5V on Arduino
S - D4 on Arduino

The Arduino was powered through an external power supply with stable 12V power directly through Vin and Gnd. The 12V power supply also supplied power to the relays COM port, and then through NO to a light. I had the positive side of the power supply go into a 3-way Wago clamp, dividing power to Arduino Nano and to COM part of relay. The negative part went into a 3-way with Arduino Nano and the Solenoid.

The thing was that when the card reader found a card with a certain ID, it would trigger the solenoid for 1-2 seconds. Now what happened was that the Arduino Nano worked a total of 7-8 times before it got violently hot and suddenly would not read RFID card anymore. It would also no longer upload sketches(avr500 time out). I changed the real nano with a clone nano(just popped it into the screw shield when changing nanos). The new one also burned out within 5-10 minutes. It smelled burnt.

During the time it was burning out, I had the nano hooked up to my computer to change some parameters. Not sure if this is why it happened.

After burning out all the Nanos I have on hand, I exchanged it for a Arduino Uno clone(a duemilove) and this has been working perfectly for a while.

Now - I have a few suspects:

  1. The screw shield. Maybe I shorted it out when I screwed it onto the wood? The screws covered the entire hole, and it may have been large enough to connect parts of the pcb board to eachother?
  2. The nanos had some sort of defect - however, this would probably not affect both the clone and real?
  3. Maybe some electrical surge goes back to the Arduino from the relay?

What could be wrong with my project here?

take my advice with a grain of salt, as i just learned dangers of relays the hard way... and am new to the micro controller hobby.

if i would place my money anywhere it would be the relay. relays are quite volatile when it comes to backlash from the power input to incorrect wiring.

lets assume you got your wiring wrong, and all the code is correct. stop. dont do the same configuration again because you will be burning through boards like cheap candy.

  1. i highly suggest getting a relay module (they cost around 5 bucks on amazon) which come with optocouplers which isolate the relay from the arduino input (for the most part). the relay module removes the need to attach the relay via breadboard/ protoboard and also reduces the risk of incorrect wiring.
  2. add a relay in your connection between powering the relay module and arduino to prevent background noise and emf backlash. this was my problem.
  3. if possible, isolate your aduino from the relay as much as possible by supplying the relay module with an external 5V power source. relays tend to draw more current from smaller arduinos than they can supply and end up damaging pins or causing brownouts.

good luck. cheers.

One more reason could be the solenoid. Try not using 12V peripheral devices with Arduinos, I had burnt two Megas in similar fashion when I tried to use 12V DC geared motors.

Nandan_Shukla:
One more reason could be the solenoid. Try not using 12V peripheral devices with Arduinos, I had burnt two Megas in similar fashion when I tried to use 12V DC geared motors.

If you burn out two Megas then you were doing something wrong, there's no problem using 12V devices with an Arduino as long as you do it correctly.

OP, we'll need some more details to be sure but from what you have described I imagine the relay will be drawing too much current, and also doesn't have the requisite diode to protect against back EMF. Can you post a link to the exact model of relay you have? Can you also please draw up a circuit diagram and post that? Hand-drawn on a piece of paper is fine, just make sure it is clear enough that we can see everything.

There is no problem with driving relays .
The problems usually are:

  1. No flyback diode on relay coils ( or other inductive devices) . When the relay switches , the coil inductance creates a high voltage spike...
  2. Powering devices from the Arduino . A good rule is don’t ( if you can’t work out the regulators dissipation for example) . The regulator on board is tiny and suffers as it try’s to dissipate any power - especially with higher input voltages. Don’t power anything from the 5v pin . If in doubt seek advice !
  3. Wiring errors or plugging /unplugging stuff whilst powered.

If you blow up an Arduino ,stop bad find out why . They are very reliable and don’t usually fail in their own .