Why does Arduino work on Windows XP and not Mac OSX?

Hi, I'm quite new to Arduino and was hoping for a little insight or a fix to this issue.

I'm running XP on a bootcamp partition on my macbook which has Mac OSX(10.6). I downloaded and installed Arduino 1.0 on both operating systems, and used the 'sweep' example from the Learning area.

On the Mac OSX(10.6) side, the example never compiles saying ' error: wiring.h: No such file or directory '

Where as on XP, there's no problem what so ever.

I followed the installation guides for both operating systems and this is still the case. Has anyone else experienced similar issues? Or has anyone worked out a solution?


Arduino 0.22 and Arduino 1.0 have both worked just fine on my MacBook Pro under 10.5 (Leopard), 10.6 (Snow Leopard), and 10.7 (Lion).

Are you running File->Examples->Servo->Sweep? Are you accidentally using a 0.22 library with 1.0?

That error message is what you get when your libary and your arduino are at diffrent versions. Nothing to do with the fact you have a Mac, it works on my Macs.

Ahhh thank you!

My error was that I reinstalled Arduino.app but never deleted my old Arduino directory - apologise, super rookie mistake, thanks again :sweat_smile: