Why does this board not work???

I designed this board for a college project. It is very simple. It is a stand alone Arduino. I soldered all of the components to the board, wired up the power supply, and it doesn't work. I have been pulling my hair out trying to troubleshoot this thing. Any help/advice would be awesome.

I supply 5V to the board and pin 1 of the "LEDs" header (digital pin 2, I think) stays at 5V. This happens with a simple program which sets the pinMode(1, OUTPUT); in setup and then digitalWrite(1, LOW); in the loop or in setup...

Here is the schematic used:

Your description is not consistent, you said pinMode(1,... and digital pin 2 together, but why? Plus your led pin 1 is on arduino digital pin 1, which is TX. Simple mistake?

I made a mistake in my original post. The "LEDs" pin 1 is connected to the digital pin 1. Therefor I only used the number '1' in my pinMode and digitalWrite. Also, what difference would it make if I used the tx pin as digital pin 1. This is in fact what it is, right? I am not using any Serial functions in the code...

void setup() {
  pinMode(1, OUTPUT);
  //digitalWrite(1, LOW); here yields the same result
}

void loop() {
  digitalWrite(1,LOW);
}

Are you seeing the same behavior on other pins?

I wonder if the bootloader has left the TX pin in serial mode. Does putting Serial.end(); as the first line in setup make a difference?

and it doesn't work

What exactly do you mean by this? Has it a boot loder on it and it won't upload or have you put a pre programmed device in and it won't function?

Using Pins 0 & 1 make uploading difficult or impossible unless you switch the out during uploading.

This makes me think whether the chip is working at all. If the chip is not working for some reason, it's put into the reset state, where all pins are set to inputs (with 10K pull-up,right?). Then you may get 5V. If you try another pin like James suggested, just flicker one other LED, will you see the action or not?

Maybe the power supply, which you didn't show, is not able to supply enough current and its voltage drops below the brown-out level of the chip. How many LEDs are you running off the board? All 7? ATMEGA can only source like 200mA total and 40mA max on each pin.

where all pins are set to inputs (with 10K pull-up,right?).

No the pull up resistors are not enabled in the reset state the input pins float.

I am using an ATMega that I programmed in my Duemelinove. It works in the development board, just not in mine. I have even tried supplying the board with regulated 5V from the USB powered dev board. Im sure it has to do with my board. Perhaps the layout of the crystal is bad?? I don't know anything about RF stuff or what the t 22pF caps do. I just know to use them.

This board runs 7 2.5W LEDs, however the micro only has to switch some N-channel MOSFETs to control the LEDs. Also, the LEDs run from a separate supply (with common ground) to prevent brown out and it exhibits the previously mentioned behavior with and WITHOUT the LEDs attached.

Your board sounds like the problem, but none of the ideas you present really makes any sense.

What were the results of two of the already suggested ideas:

  1. Measure voltage on another pin
  2. Flash a LED on another pin

What happens when you take the microcontroller chip out? Do you still give 5 volts on the trace?

The other pins are at 0V when "running" the previously mentioned code. When I power up the board with no micro the pin is at 0V. Trying the above code with a different pin yields the same result. It looks like the code isn't being run on the micro or something.

Check to make sure you mounted the reset button in the correct orientation. If you mounted it 90 degrees out you will be in continual reset. Measure the voltage at pin 1.

I can't imagine I would rotate the button by 90 degrees, very hard to push it in. As I suggested, the chip may be at a reset status. Measure atmega pin 1, do you have 5V, if not it is reset.

You know... this happened to me more than once... I made the board backwards.

That supposed to be the side where you place the components?... (If is not, is backwards). The silk of the components makes it looks that that's the problem. Eagle did this to me with Arduino schematics more than once and the only solution is just to mirror the design.

If that's the problem all what you have to do to save that PCB is to solder the chip from the other side of the board.

now, let say is not backwards…

Here is another similar schematic.

20 and 21 on the first schematic are going to VCC, while your 21 is going to ground through a capacitor… why?.. (bypass?). Is not acting as a bypass… Is it?

Another thing… I don’t know if you are using ceramic capacitors, but in your schematic those capacitors (22,21,20) are placed with the polarity reversed.

Edit: never mind with the the 21, that is a filter, but again… check the polarity of those capacitors in case you are not using ceramics.

… and the reset button too, that’s another common error.