why won't my SB-Freedunio load any programs

hi I have a SB-Freedunio and it won't upload any sketches I have read all stuff on the arduino web-page and itsa still not working

Won't get much help without more details.

  • What operating system are you using?

  • Get any errors? (copy and paste)

  • What do the LEDs do when you upload? (Is green power light on? Is pin 13 light doing anything? When you upload do TX and RX flash? How? One or 2 really quick flashes then that's it? Or do they flash back and forth for a few seconds then stop?)

  • Copy and paste the code you are trying to upload.

most of the time it just times out

all the leds are working when its pulged into the usb cable the power light is fine, the TX light blinks intermittently and the led connected to pin 13 blinks as-well.

i'm just trying to up load the Analog input, analog output, serial output example code

Has the board ever worked?

yes i have downloaded the blink program and that worked

I had a similar but slightly different problem a few weeks ago. In my problem 13 pin was blinking very fast (faster than the basic blink program) and I couldn't upload. Finally after a lot of research this worked to let me upload:

  1. Get the Blink sketch ready and have Arduino unplugged
  2. Hold down the reset button on Arduino
  3. Plug in USB. Keep holding reset
  4. Upload the sketch. Watch the screen for the "done compiling" message. (I don't remember exact wording right now.)
  5. The second you see that message release the reset button

You may have to work with the timing. I had to try 3 or 4 times. Try releasing right when you see it. If it doesn't work wait 1/4 second from compile message showing then release. Then try 1/2 second. etc....

Good luck.

thanks I'll try that

thanks for the help but i think its to do with my laptop rather than my board i tried it on another computer and it worked fine through it's still mystifying why its not working oh well