WiFi 101 Shield Does Not Connect; No indicator lights; have resetted many times

I have an Arduino WiFi 101 shield connected to an Arduino Uno board. I have bought the shield a few months ago, but cannot connect to a network when I tried the connecting to WPA to connect to my home network. The code can be found here:

Also, none of the lights WIFI, NETWORK, ERROR were on during the attempted connection. When I tried to get the Mac address to print out, the output was all zeroes. I have checked and identified the out-of-date firmware as a possible problem. I also have verified that the SSID and the password is correct. Any ideas on getting the shield to connect or to update the firmware?

Thanks in advance!

Hi @huanglx, Please downgrade to 0.7.0 of the WiFi101 library until issues with v0.8.0 and the Uno are resolved.

Im having problem with Wifi Shield as Well, But my problem is upgrading Wifi Shield Firmarwe, someone has had success with this?

I also get the message WiFi shield not present
I'm using a arduino uno R3 with WiFi shield 101
I see the suggestion to down grade to 0.7.0 of the WiFi101 library
but I'm new to arduino so if anybody could tell me how to do so
that would be great

thanks for your help