WiFi 101 Shield Trouble With Arduino 101 and Arduino Zero

I recently got an Arduino 101 and an Arduino Zero for my birthday. I put the two WiFi 101 Shields I have on them. I tried uploading a test program to them with the port /dev/cu.usbmodem1431. On both the Arduino 101 and the Arduino Zero I get an upload error. Below are the errors for both boards.

101 Error

	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:162)
	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
	at processing.app.Sketch.upload(Sketch.java:1186)
	at processing.app.Sketch.exportApplet(Sketch.java:1160)
	at processing.app.Sketch.exportApplet(Sketch.java:1132)
	at processing.app.Editor$DefaultExportHandler.run(Editor.java:2409)
	at java.lang.Thread.run(Thread.java:745)
Caused by: processing.app.SerialException: Error touching serial port '/dev/cu.usbmodem1431'.
	at processing.app.Serial.touchForCDCReset(Serial.java:87)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:146)
	... 6 more
Caused by: jssc.SerialPortException: Port name - /dev/cu.usbmodem1431; Method name - openPort(); Exception type - Port not found.
	at jssc.SerialPort.openPort(SerialPort.java:167)
	at processing.app.Serial.touchForCDCReset(Serial.java:81)
	... 7 more

Zero (Programming Port) Error

Open On-Chip Debugger 0.9.0-gd4b7679 (2015-06-10-19:16)
Licensed under GNU GPL v2
For bug reports, read
debug_level: 0
adapter speed: 500 kHz
adapter_nsrst_delay: 100
cortex_m reset_config sysresetreq
Error: unable to find CMSIS-DAP device
Error: No Valid JTAG Interface Configured.

My operating system is Mac OS X 10.11.4 and my Arduino IDE is 1.6.9.

I don't have a WiFi 101 Shield, but if you post your code, I'll see if it will run on my 101.

I don't have a WiFi 101 Shield, but if you post your code, I'll see if it will run on my 101.

As far as I have been able to find, It isn't the code and instead a problem with the connection. Though if you want the code it is below.

#include <SPI.h>
#include <WiFi101.h>

char ssid[] = "Name Here";
char pass[] = "***********";
int status = WL_IDLE_STATUS;

WiFiServer server(80);

boolean l1 = false;
boolean l2 = false;

void setup() {

  if (WiFi.status() == WL_NO_SHIELD) {
    Serial.println("WiFi shield not present");
    while (true);

  pinMode(8, OUTPUT);
  pinMode(9, OUTPUT);

  while (status != WL_CONNECTED) {
    status = WiFi.begin(ssid, pass);

  IPAddress ip = WiFi.localIP();
  Serial.print("IP: ");

void loop() {
  WiFiClient client = server.available();
  if (client) {
    boolean currentLineIsBlank = true;
    String chead = "";
    while (client.connected()) {
      if (client.available()) {
        char c = client.read();
        if (String(c) == "\n" && currentLineIsBlank) {
          if (chead.startsWith("GET / ")) {
            client.print("HTTP/1.1 200 OK\n");
            client.print("Content-Type: text/html\n");
            client.print("Connection: close\n\n");
            client.print("<!DOCTYPE HTML>\n");
            client.print("<html><head><title>Arduino Zero</title></head><body><h1>Hello</h1></body></html>\n");
        if (String(c) == "\n") {
          currentLineIsBlank = true;
        }else if (String(c) != "\r") {
          currentLineIsBlank = false;
        chead += c;
    Serial.println("client disonnected");

I can't get the code to compile. I keep getting this error (I've tried on 1.6.7 and 1.6.9)

Arduino: 1.6.9 (Windows 7), Board: "Arduino/Genuino 101"

C:\Users\Nathan Camp\Documents\Arduino\libraries\WiFi101-master\src\WiFiMDNSResponder.cpp: In member function 'bool WiFiMDNSResponder::parseRequest()':

C:\Users\Nathan Camp\Documents\Arduino\libraries\WiFi101-master\src\WiFiMDNSResponder.cpp:155:61: error: 'memcmp_P' was not declared in this scope

     if (memcmp_P(request, expectedRequestHeader, HEADER_SIZE) == 0 &&            // request header match


exit status 1
Error compiling for board Arduino/Genuino 101.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

It compiles fine if I set the board to Uno

I have fixed the problem by disabling SIP in OS X.