Wifi connected but IP ping timeout

Hello everyone,
I’m just starting with arduino, need wifi for my project and have a connection problem:

→ when I connect the Yun to my home-wifi as a client, I cannot open die web-panel by typing in the IP adress in my browser or ping it (timeout), the same when i try to connect with putty (no connection). In the advanced settings I can see that wifi is connected, but I cannot reach the IP.

What I have tried so far:

  1. Connect to the Yuns wifi, when its set to AP-mode → working
  2. Connect by cable-ethernet → working, this is how I change settings at the moment
  3. Upload sketches by USB → working

Setup:
My PC is connected to a Wifi-router by cable, I have no problems with other devices like my smartphone (can ping the IP of the phone from my pc when it’s connected by wifi). Wifi is hidden, no dhcp, all devices get static ip-adresses with the same subnet-mask.

I’m not very familiar with router- or firewall settings. I can ping the router from my pc, but when I use the network-utility of the yun (Network - Diagnostics), I cannot ping the router.

I also tried to setup the router as dhcp to give the yun an ip-address, this worked fine but this given IP i cannot ping also…

Since I get timeouts when pinging the yun and not the message “not found”, I think there is something blocking the connection. I also tried to switch off all software-firewalls on my pc but nothing changed.

Do I have to setup anything in my router or the yun to allow a connection to the wifi-IP-address of the yun?

I had a similar problem, did the wifi setup via my phone using the IP address

@BastelJoergi can you run example sketch WifiStatus (upload it via usb cable), then open serial monitor and paste the output here?

@Federico Fissore: I did that, but I only got the same Information as from die Luci/advanced setting: Wifi ok, signal 60%, IP adresses etc. all like I set up

But the problem is solved now!

After reading the post of mikeruss, I remebered a topic here, where someone wrote something like "when you want to use wifi for the yun, never touch an ethernet-cable to set anything up! Do it all by only using wifi"

So here is what I did:
1.) switched on dhcp on my router, configured an ip-range
2.) Reset the firmware of the yun: I already downloaded the latest version and uploaded it before, but I left it on the SD-card I put into my yun. On the welcome page, I klicked on Reset (again) and waited for the process to complete
3.) unplugged the ethernet-cable from the yun and "never touched it again" :wink:
4.) switched on my wifi card in my pc, connected to the yuns default-wifi
5.) setup my wifi on the yun like in the getting started, didnt use the advanced options this time
6.) looked into my router: it shows all connected wifi devices and their ip-adresses -> got the ip-adress of the yun givin by the router/dhcp
7.) pinged this ip-adress -> worked, opened the yun-webpage -> worked now!
8.) changed the advanced settings of the yun from dhcp to static ip-adress
9.) switched dhcp off in my router

So when I look at the settings now, it is exactly the same as before, but now everything works...very strange. So it doesnt only depend on WHAT you set up, but also HOW you set it up.

I'm happy that everything works now, but maybe i will try to reproduce the problem to verify this "when using cable-ethernet to set up the yun, wifi doesnt work correctly anymore"...

Ah sorry, I missed you were using static ip addresses. This cases can only be handled via advanced configuration panel, as you did. Well done!