WiFi Shield and WEP Networks?

Hi Guys,

I am trying to get my WiFi Shield to connect to a WEP network with no success. I can connect to a WPA network with no issues so I know the shield is working. I have several devices on this WEP network all using the same settings (ssid, keyIndex, key) with no issues.

Running the ConnectWithWEP sketch I only get an error light on the shield and the Serial terminal is displaying "Attempting to connect to WEP network, SSID: TESTNET". I do not have an FTDI cable to monitor the wifi shield itself.

Any ideas on what else to check? Since this is an already-in-place network, switching everything to WPA is no small task and at this point, is not an option.

Thanks in advance.

Just an update. I managed to get it to connect to a 40-bit WEP network but not a 128-bit WEP network. I'm using the HEX key as my password. Should I be using something else? This is the same HEX key I use for all other devices on the network.


Break 128bit WEP network in 137sec


40-bit WEP is 2^88 time weaker than 128bit WEP


Time took to break 40-bit WEP= 137/309,485,009,821,345,068,724,781,056 = 0.00 sec

Save yourself time do not do WEP.

I know WEP is worthless, but this isn't my network. We can't cut over to WPA until we get access to one device owned by ...blah blah blah. Long story short, I'm stuck with WEP at this location for a while.

I think the issue is related to the keyIndex variable. The AP is using key 1. I have set the Arduino to key 1 but still no dice.

Any ideas?


You could use router load openwrt as wifi shield for Arduino, It will support wep 40/64/128 bits very easily.
The openwrt is Linux Kernel base, you load additional software ( apache, mysql...) to help Arduino. Every thing should worked as long as you are not Linux Kernel Panic, but only Windows. :grin:

I haven't thought of that. I'll have to check it out. Thanks

And a Kernel Panic is a Kernel Panic. Regardless if it's in the form of a BOSD or a SegFault of Doom. XD

Any luck here guys? I'm not sure about using Linux to make this shield work on wep networks.

I've trolled the net and can't find a solution. I have not updated firmware on either UNO r3 or wifi.

Do I need to? WPA works fine I just have to work with an established network that I can't change. Surely someone has dealt with this and solved it easily. Can you advice a working firmware for WEP please.