WiFi Shield client.connect fails

I read all messages, but I cannot find a solution to my problem.

The WiFi shield connects to the WiFi, but it won't connect to the server. I use the WiFi Client example.

I have an official Arduino WiFi Shield with the AT32UC3A1512 chip. I use the IDE 1.6.5. I updated the Firmware on the Shield (wifi_dnld and wifiHD) to 1.1.0.

The result I get (including additional output) is:
Attempting to connect to SSID: MyWiFi
Connected to wifi
SSID: MyWiFi
IP Address: 192.168.1.100
signal strength (RSSI):-64 dBm
WiFi Status:3
Encryption Type:4
Firmware Vwersion:1.1.0

But whatver I do, the client.connect(server) does not work. I use the IP from the example: IPAddress server(192,168,1,1);

Can anyone help me?

I use the IP from the example: IPAddress server(192,168,1,1);

Are you certain that is the IP of a server? That is normally the gateway IP.

You are right, that's the gateway. I tried several pages. But the gateway should come up with the login page and have a less latency. It still doesn't work.

Did you change the server to IPAddress instead of char? You don't want to use dns. That could fail.

IPAddress server(192,168,1,1);

edit: If you have as in your first post, then the only thing that causes a fail on every IP or domain is the failure of the firmware upgrade to 1.1.0, but it looks like that is ok also. Don't know what to tell you.