WiFi shield connects to WiFi network but can't interact: ERR_ADDRESS_UNREACHABLE

Hello.

I have a Arduino Uno and a WiFi shield ; the project goal is to aquire data from a sensor and to send it to a Processing sketch running on a PC over WiFi.

Taking most of my code from the various official exemples, I managed to have the WiFi shield to successfully connect to a WiFi (WPA) network (according to the board and the smartphone hosting the network).

However, when I try to send/receive data from the board, I always get an error, and I do not know where it is from.

I doubt the error comes from my code, as it's almost only copy and pastes, but here are the relevant parts just in case :

Initilization :

char ssid[] = "MiniStepper";            // Nom du réseau
char pass[] = "Test1234";               // Code ou clef
int keyIndex = 0;                       // Network key
int statut = WL_IDLE_STATUS;
WiFiServer server(80);

Setup :

void beginWiFi(){ // called in setup()
  // Connection to the network (working, so omitted)
  //...

  server.begin();
}

Answering to requests :

void connexionRead(){ // called in loop()

  WiFiClient client = server.available();
  if(!client) return;
  
  Serial.println("New connexion !");          // This never prints, so I'm sure the problem is earlier

  // ...code sending back a HTML file with the HTTP protocol
}

I'm doing access using Chrome (I tried Firefox with no results as well), using the IP Address given by WiFi.localIP() (the smartphone hosting the network gives the same) :

http://192.168.43.200/

which gives back "ERR_ADDRESS_UNREACHABLE".

I'm really new to IoT, and I'm guessing it's probably a config problem (firewall, ...) ;
my computer is running Ubuntu 15.10 (Willy Werewolf) (I tried with the same results with a Windows 7 PC),
the network is encrypted by WPA, hosted by a XPeria U (I tried with other smartphone-hosted WPA networks with the same results),
the arduino WiFi shield with Uno board (bought less than 3 months ago so I'm guessing it's the latest version).

Is there anything I missed ?