WIFI Shield - Firmware upgrade fail

Been trying to upgrade the firmware on my new WIFI shield. Keep getting this error in cmd prompt. Followed the instructions from here: http://arduino.cc/en/Hacking/WiFiShieldFirmwareUpgrading

"Parsing ELF file… Can’t open input file “/Arduino/hardware
/arduino/firmware/wifishield/binary/wifi_dnld.elf”
FAIL Reading error

Happens for both wifi_dnld.elf and wifiHD.elf

Using R3 on IDE 1.0.5, window 7 64-bit. Tried downloading the latest firmwares on github, already have the 2 firmware pins jumped. Tried changing file permissions. Sketches upload fine, serial monitor shows WIFI shield not present.

Any ideas?

Thanks

Untitled.png

Followed Ludgy's instructions here: Wifi shield pinging but not serving page - Networking, Protocols, and Devices - Arduino Forum

Fixed it!

Don't know if it was my ELF files or the directory.

Just giving props to Ludgy’s fix. (Link is above).

Darned if I can see what the problem was. Maybe corrupt files that I downloaded from GitHub. (Dang, that site is a pain to deal with.)

But, whatever the reason, his files successfully flashed the card, and his sketch successfully serves his web page.

Figured recommending his fix was the appropriate thing to do.

I cheat. I copied both those files to my root directory from the
/arduino-1.0.5/hardware/arduino/firmwares/wifishield/binary/ directory.
That makes the commands easy.

batchisp.exe -device AT32UC3A1256 -hardware usb -operation erase f memory flash blankcheck loadbuffer c:/wifi_dnld.elf program verify start reset 0

batchisp.exe -device AT32UC3A1256 -hardware usb -operation erase f memory flash blankcheck loadbuffer c:/wifiHD.elf program verify start reset 0