WiFi shield problems

Basically, I'm getting the "WiFi shield not present" error. Here's the situation:

I have a new wifi shield, a mega adk, and an unoR2. I plugged the shield into the mega, and loaded the "ScanNetworks" sketch from the examples built into v1.0.4. Worked great, found ~8 local networks and listed them in the serial terminal. I tried some other sketches, but couldn't connect to a network. I figured it was because the SPI pins are different on the mega, so I put the shield on my uno instead

On the Uno, I got the "WiFi shield not present" message. I tried a few things not really important to the discussion here, but eventually decided to go back to the mega. Now on the mega, I'm getting the same error message. I'm pretty confident my setup is now the same as what I had working before.

Has anyone had problems like this? I'm not sure what to check. What was working now isn't, which is frustrating. Any troubleshooting tips are appreciated.

And now it's working on the uno... (the scan tool at least)
Intermittent problems are the hardest to troubleshoot. Any advice welcome...

have you put out the J3 jumper and when you use arduino uno R2 have you create a link with a simple wire between IOREF pin and 3.3 V pin?