WiFiNINA Updater Error validating flashed firmware

The most terrible part of this issue is that after a few hours of figuring out how to configure everything correctly, I was able to get it working with some of the simple examples in the WiFININA sketches. Then I was reading some notes about the tools and ran the CheckFirmwareVersion program. I got an error message that the firmware version was incorrect and decided to use the Updater to update the firmware. That’s when the nightmare began. The firmware seems to have been erased but the update failed in the verify step.

I can no longer upload any sketch at all to the UNO, not even the Blink sketch. If I can’t resolve this soon I will have to try to return the board for a refund because it is useless to me now. It’s a shame that I was following notes and instructions published on the Arduino website when this situation arose.

I have run this for versions 1.2.4, 1.2.3, 1.2.2 and 1.2.1 with the same results, as follows:

  1. Test the connection to the USB port (always OK).
  2. Run the updater sketch from the Arduino IDE (1.8.10), Raspberry Pi Linux version
  3. Update the firmware (always fails with the same error, example attached)

I’ve seen similar posts from others who have had this happen recently and tried a couple of suggestions provide but none of them have worked.

Some additional device info:
pi@raspberrypi:~ $ cat /proc/cpuinfo
processor : 0
model name : ARMv7 Processor rev 4 (v7l)
BogoMIPS : 38.40
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

Hardware : BCM2835
Revision : a020d3
Serial : 00000000a1d6aa96
Model : Raspberry Pi 3 Model B Plus Rev 1.3

pi@raspberrypi:~ $ lsusb
Bus 001 Device 004: ID 03eb:2145 Atmel Corp. ATMEGA328P-XMINI (CDC ACM)
Bus 001 Device 006: ID 2222:3100 MacAlly
Bus 001 Device 005: ID 258a:0001
Bus 001 Device 007: ID 0424:7800 Standard Microsystems Corp.
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

FirmwareUpdateError1-2-4.txt (17 KB)