wifly et spi bauderate

bonjours à tous,

me revoici avec mon wifly indomptable.

voici mon petit problème

j'utilise un programme sur mon arduino qui demande beaucoup d'écriture sur le wifly en un temps restreint, le soucis c'est que le wifly perd régulièrement les pédales, au lieu d'émettre ma série de phrase comme il devrait, il fait soit un freeze complet alors que l'arduino fonctionne toujours ( j'ai un double de l’émission sur le port série qui est correcte), soit il commence à émettre correctement et en cours d'émission bascule en mode configuration wifly et balance tous ce qu'il a de configurer.

Je suppose que je dois demander au SPI d'envoyer trop d'information au wifly et certain caractères sont erronés et plante l’émetteur. C'est juste une supposition.

Donc j'ai voulu modifier la fréquente sur les deux éléments, le wifly et l'arduino.

le wifly nickel je lui ai envoyer ceci via le module de commande:

$$$ set u b 57600 save reboot

il m'a répondu AOK à chaque fois sauf après le reboot ou j'ai perdu la transmition ce qui est normal vue qu'il n'est plus synchrone avec l'arduino.

je l'ai interrogé via le wifi il réponde est tout est bien configurer.

Mais voilà le soucis, je n'arrive pas à configurer l'arduino pour passer le spiuart à 57600, j'ai essayer sur les anciennes librairies et les nouvelles je n'ai pas trouvé ou réussi, car toujours pour simplifié la chose toutes les librairie sont codés pour des quartzs à12 ou 14 MHZ mais pas pour des 16 MHZ

D'ailleur voici l'adresse des nouvelles bibliothèques y a de nouveau truc intéressants https://github.com/sparkfun/WiFly-Shield/tree/master/src.

si quelqu'un pouvait m'aider car là je patine,

merci d'avance Flo

:drooling_face: quelque chose me dit que j'ai encore demandé un truc rare est chiant :grin:

je me permet de faire un dernier petit up, après je laisserai tomber le sujet. =(

Une piste (?) : -> http://forum.sparkfun.com/viewtopic.php?f=32&t=25216

Mais difficile à dire étant donné que je ne peux pas tester...