WiFly is giving garbage on serial terminal

Hi
I had an old Wifly Sparkfun board lying around RN-131C with version 2.23 on it. I managed to get a good connection using the SpiUartTerminal tool and upgreded to version 4.00.
It starts up nice but when I type “get everything” it garbles the serial output to the terminal. I added the serial log. Any ideas?

SPI UART on WiFly Shield terminal tool
--------------------------------------

This is a tool to help you troubleshoot problems with the WiFly shield.
For consistent results unplug & replug power to your Arduino and WiFly shield.
(Ensure the serial monitor is not open when you remove power.)

Attempting to connect to SPI UART...
Connected to SPI UART.

 * Use $$ (with no line ending) to enter WiFly command mode. ("CMD")
 * Then send each command followed by a carriage return.

Waiting for input.

$$

ERR: ?-Cmd
<4.00> 
get everything

wifly-GSX Ver 4.00.1, Apr 19 2013 11:48:31 on 131C11
Beacon=102
Reboot=0
IF=DOWN
HOI00:0N5520G.0
S..2
R=PM14LS7TO0
CP0.ONP
L=L
MEEOFsz4
tC=
sm=Iee0ma$N00
mn
cp.rhc
a=0F=.0
iwySm
roga=s3ipiTe=0To=
SVe
a0xn
o0u=NM=1
t12MLk-r3Lk-30apszn
AdsdEU=as
eT0aT0Tg=
to0Inx
a=0
V=0eg=0rL=
ahrbpTE=TE=9151
e
ua90l0
d0
dI
om1
ecx
veWlSPsd
m0
gl
ee
A2..555
tv0
c=00
nr0ee=04>
<4.00> 
Joining Verelec now..
Associated!
DHCP: Start
DHCP in 1222ms, lease=86400s
IF=UP
DHCP=ON
IP=192.168.0.12:2000
NM=255.255.255.0
GW=.81Len0


<4.00> 
get everything

wifly-GSX Ver 4.00.1, Apr 19 2013 11:48:31 on 131C11
Beacon=102
Reboot=0
IF=UP
DH=
=2812
M555
W26.
T0.0
O=,T1
L=
CD0
C=.0P=E
O*O
M=E*lhe4
ch0Fhm5dTr
da
S960
mn
c=.rhc
a80F0.:
lwyXmUrvgaPs
iuiTo=
To=
IVl
a
xt
i0uONa=f
t22bLm-r0Lm-30ahs5n
PdedAU=ps
em0am0rg0
tn0onx
a00
V=
eR=
rL0
uh=bpiE0TA=9852
e
ut9
l0
dx
_I
im0
pcx
vIWySPwdFm0
g=
re
S22..55
ta0
c=.0
n=0eP=
4>