Wifly Issues

Hi everyone. I am having issues with my Wifly (https://www.sparkfun.com/products/9954). The arduino board is a Mega 2560.

I have tried and successfully uploaded the autoconnect and webserver scripts. However the leds do not change with or without a wifly script (PI04 is slow blinking and PI06 is fast flashing), looking at my router (Asus WL-520GU [DD-WRT]) no new client is connecting.

What is the best way to trouble shoot this issue? Should these leds be flashing like that?

Thank you in advanced.

James

Have you tried the example "SpiUartTerminal " ? I assume that - as the shield is for SPI on Pins 10-13 designed - you need to connect the different SPI Pins from the Mega.
With the Terminal Example you could setup the WiFly initially to ensure it works. E.g. you will need to setup Flow Control ( RTS/CTS ) between the Roving Modul and the SpiUart on the Sparkfun Board.
I was also updating to the latest Firmware - an excellent test whether you could get connections from the Roving Modul to the Internet.

Peacekeeper is right, the WiFly Shield is not compatible with the Mega2560. You have to reroute the shield's pins 13, 12 and 11 to 52, 50 and 51 respectively. Depending on the library you use you may have to leave pin 10 as it is or also reroute it to pin 53 of the Mega2560. In any case you have to ensure that pin 53 is set as an output to ensure the SPI hardware is working correctly.