Will not connect on correct com port

It will not connect any more at all, an arduino Uno. Not sure why. It just stopped making the connect when I plug it in.

Reburned a bootloader to it using the method described within the forum, using a mega board. Looked like it did something when I got everything done right, but still no blinking on 13, nor will it show on the computer as connected via a com port. Tried on a different computer and no luck, tried another cord, same. It will power with a battery at the battery port but 13 stays solid. The only thing not exactly to the instructions was I had to use a 100 nf over a 10 nf capicator as I didn't have one the right size

Did I somehow fry a chip?

You might have damaged the USB to Serial chip (either a 8u2 or 16u2 depending on board rev). Re-burning the bootloader of the ATmega328 won't have an effect on the device showing up as a COM port.

You might try re-loading the 8u2/16u2 firmware. http://arduino.cc/en/Hacking/DFUProgramming8U2

Well thanks anyhow, went through all that and the thing just would not get recognized by anything, even though it powers up. No flickering on rx or tx at all though