Win 10 not allocating COM to Arduino Mega

So - anyone had trouble getting Windows 10 to allocate a COM port to an Arduino Mega?
I'm sure it worked before I updated
I've mostly been using nano's with the CH340 ship, and they work fine still, using both the desktop IDE and the cloud based one
But I can't get it to see the Mega for uploading - the AtMega 2560 shows up as a device under ports in the Device Manager, but no COM port is allocated to it
I know they use the ATmega16U2 for USB communication, which should be in the Arduino IDE driver library
The USB leads and boards all work fine, as I have managed to get it all working on my sons laptop, which runs Win8 still, and the USB ports are working fine for the nanos
When I try uploading using the only COM port on offer, COM1, I get:
....
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

I have also tried manually reinstalling the driver for the mega, and uninstalling and reinstalling the Arduino IDE and all its associated drivers

I've wasted a number of hours trying to figure this out today, so any tips would be appreciated

(deleted)

I have 2 originals and 5 clones, none of them are working on my desktop, but they all work on my son's laptop with a new Arduino IDE install on it
The nano's I'm using are all clones that use the CH340 chip, for which I have the installed drivers and they work fine on the desktop

USB 2.0 ports or 3.0 ports ?

tried both, no luck on either - Atmega2560 shows up under ports on device manager, but no Com port is allocated to it for the IDE to communicate with it
Tried 2 megas at once, still nothing, tried a mega and a nano, the nano pops up

It's driving me nuts

And you are looking at "hidden devices" in win 10 to see the com ports ?

when I connect a Mega to the USB it shows up without looking at "Hidden Devices" in the Ports (COM & LPT), but it doesn't seem to havea COM port assigned to it - a least not one that shows up in the standard Arduino IDE or any other IDE's, online or otherwise

A screen shot of what you are seeing in device manager might be useful.