Win 7 Arduino Uno BSOD

Hey guys,

I am using Windows 7 x64 and an arduino uno. It uses the pc's power source to power up some LEDs and it's connected to the pc via USB. It works perfectly fine while the pc is running, but whenever I try to shut it down there is a blue screen and it restarts. That doesn't happen whenever I disconnect the arduino so it's clearly the problem.

I analysed the crash dumps and it shows me stuff like this:

On Thu 28.02.2013 21:48:22 GMT your computer crashed crash dump file: C:\Windows\Minidump\030113-20311-01.dmp This was probably caused by the following module: usbport.sys (USBPORT+0x16F4B) Bugcheck code: 0xFE (0x4, 0xFFFFFA800B6ADBD0, 0xFFFFFA800AC748D0, 0xFFFFFA80082A6C00) Error: BUGCODE_USB_DRIVER file path: C:\Windows\system32\drivers\usbport.sys product: Betriebssystem Microsoft® Windows® company: Microsoft Corporation description: USB 1.1 & 2.0-Porttreiber Bug check description: This indicates that an error has occurred in a Universal Serial Bus (USB) driver. The crash took place in a standard Microsoft module. Your system configuration may be incorrect. Possibly this problem is caused by another driver on your system which cannot be identified at this time.

So there is some kind of problem with the usb-driver...

any ideas on what to do?

Be very very careful while using USB port for powering up external current consuming devices. Practically USBs are designed to supply upto 500mA current but when you connect components like led etc. with arduino board (no external power source), by any chance if there is a short circuit, they'll draw a HUGE amount of current from the USB. That may harm your computer. So either power on the arduino from an external power source & do the programming + demonstration, or use the usb only to program the arduino, not to light led's or other electronic components.

Thanks.

There might have been a misunderstanding here :wink:
The LEDs are powered by the pc (directly from the power source). The arduino only controls them (via transistors).

So has anyone an idea how to fix the problem?

What is the size and timestamp of usbport.sys?

Size 0x00056000 Timestamp 0x4d8c0c08

LastSamurai: Timestamp 0x4d8c0c08

Impossible. Timestamps are 64 bit values or human readable times. For example, "11/09/2011 09:51 AM" is the timestamp of my copy.

Size 0x00056000

On-disc size.

Why do you need the time? Yesterday evening i think. Size 798kb

LastSamurai:
Why do you need the time?

I have Windows 7 / 64 bit on this computer. The goal is to determine if your version of usbport.sys is different than mine. If they are different then one of your hardware vendors (probably the motherboard manufacturer) replaced the driver with their own. If that’s the case, you will need to put the standard Microsoft driver back in use and/or contact the folks who created the modified usbport.sys for a less buggy version.

Yesterday evening i think. Size 798kb

Ugh. Do this…

• Open a command shell…
• Click the Start button
• Type cmd and press Enter
• Type dir \usbport.sys /s and press Enter
• Copy-and-paste the results into a reply. It should look something like this…

 Directory of C:\Windows\System32\drivers

11/09/2011  09:51 AM           325,120 usbport.sys
               1 File(s)        325,120 bytes

Ahhhh! Ok, now I know what you mean ;)

25.05.2011 04:29 325.120 usbport.sys 325.120 Bytes

Given the matching size but timestamp difference I suggest you check for operating system updates.

I have installed all updates available through Windows update. I tried out a new USB cable too. Still doesn't work :( Anyone has a clue?

Does the fault occur when the LEDs are not powered / connected?

usbport.sys

12/02/2011 325,120 bytes Win7 64bit

There was another dated 11/20/2011 and 325,120 on another machine. Clearly there are newer updates.

The address "0x16F4B" is telling me that it is a device driver error (ring 3 error) B=1011 two low order bits = 3.

LastSamurai: Size 0x00056000 Timestamp 0x4d8c0c08

Can you tell me how to get the timestamp?