Win 7 mega 2560 - no serial port or drivers

Windows 7 64bit O/S. The serial port option is greyed out in the menu. Device manager shows the 2560 but no driver installed. I am try to upload a sketch but this issue remains but get serial port errors.

Have you done this, from the hardware guide - http://arduino.cc/en/Main/ArduinoBoardMega2560

Communication The Arduino Mega2560 has a number of facilities for communicating with a computer, another Arduino, or other microcontrollers. The ATmega2560 provides four hardware UARTs for TTL (5V) serial communication. An ATmega8U2 on the board channels one of these over USB and provides a virtual com port to software on the computer (Windows machines will need a .inf file, but OSX and Linux machines will recognize the board as a COM port automatically. The Arduino software includes a serial monitor which allows simple textual data to be sent to and from the board. The RX and TX LEDs on the board will flash when data is being transmitted via the ATmega8U2 chip and USB connection to the computer (but not for serial communication on pins 0 and 1).

I know about the .ini and .inf files for drivers. I have put both is the correct Win folder plus tried to install with the install option. Still no drivers found for 2560.

Do you have another suggestion?

If you have correctly installed the Arduino MEGA 2560.inf file, then I'm afraid I don't. Anyone else?

A bit of searching shows you are by no means alone in having difficulties with W7 and the new USB chip.

This post may help - http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1287724404. Then follow the link to the Adafruit forum. Good luck.

Still no answer for my Win 7 64 computer, so I installed everything on my Win XP computer and it all worked fine. So I know I am installing everything correctly. I just need to figure out how to get the drivers to work on Win 7 64.

Anyone can help here.