Windos 10 Arduino problem

I just upgraded to Windows 10. I loaded Arduino Software and tried to select port when I noticed the port had the following Info "Com4 plus 20 strange characters instead of “COM4”. When I tried to upload a sketch I got an error message see attached pdf file which shows these characters.

I tried reloading the software, rebooting, shutting down I even reloaded Arduino. I can not make the error disappear.
I think the data that appears in the port data cannot be translated by the software.

How do I remove these characters help!

Arduino.pdf (125 KB)

Sorry to tell you that microsoft products are not the most reliable in the world . . exactly.

If you want to explore the microsoft world alone you will need a big amount of patience.

Hum. I haven't thought to check serial ports since I updated my development laptop to Win10 last night (though CH340G adapters work fine on Windows 10 on my other system - none of my FT232 adapters work anywhere - (thank you very much, FTDI), and I don't have any Uno/Mega's to check the 16u2 with).