Windows 10 COM issue

Hello

Ive gotten to the point where I have to reach out for assistance. This issue is making me pull my hair out!

I plug my Arduino UNO in, the green light is on, and there's a steady blink coming from the orange led on the board... no matter how many different ways I try, I cant seem to get the drivers installed properly. On device manager, I have Unknown USB Device (Device Descriptor Request Failed).. I've attempted updating the driver manually numerous times, as well as uninstalling it and each time it tells me that "Windows has determined that the best driver for this device is already installed." I did manually browse the folder where Arduino drivers are located, and that's the message I get.. I also attempted to "Have Disk" just to see if that worked... after selecting Arduino.inf, windows tells me " The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for x64-based systems." I've tried plugging it in different USB ports, all have the same outcome. When I'm in device manager, I show hidden devices and I do NOT see any COM ports. When I run Arduino, I click on Tools, then I am unable to click on "Port" because it is grayed out.. I'm not sure if this is by default, but right above "port" it has "Board: Arduino/Genuino Uno" already selected like it knows what's plugged in. I took this board to work, and plugged it into another PC and sure as hell it worked fine..

I'm using a Gateway Windows 10 64bit desktop computer.

I apologize if I'm missing something obvious, but I don't know what else to do. I appreciate your time reading this and hopefully someone can point me in the right direction. :) Thank you

Would it be a CLONE or a real Arduino as they often need different drivers that are not supplied with the IDE.

Either CH340 or CP2102.

This is the official CH340 drivers Yes they are Chinese.

And these are the CP2102

Avoid USB 3.0 ports and leads unless you know for sure they work with Arduino.

Thank you for your response....

I made sure I tried a 2.0 port as well... didn't help..

How would i be able to determine whether or not its a clone?? I downloaded the CH340 drivers.. it was an exe.. so i just installed them... I also downloaded the CP2102... attempted to update and browsed to it... still showing me the same error screen..

To determine a clone the best bet is to post a good quality picture picture of the chip near the USB connector or post the markings so that somebody can tell from this side of the screen.

I would also recommend reading the posts near the top of this section of the forum as they contain important information about how to get the best answer quickly.

krf1786: I'm not sure if this is by default, but right above "port" it has "Board: Arduino/Genuino Uno" already selected like it knows what's plugged in.

It doesn't mean anything.

Actually that feature may be added in the future but it's not available yet and even when it is it will be an opt-in feature: https://github.com/arduino/Arduino/pull/7120

Ok.
I will keep digging like you suggested as well… thanks!

I had the same problem that I solved using a shorter cable

The blue one that was supplied is very short.. I guess it won’t hurt to try it. Thanks!

The board is from elegoo if that changes anything...

krf1786: The board is from elegoo if that changes anything...

Why do you persist in not providing the information asked for?

A quality photo of the board.

Is it too much of a bother? >:(

I did. Post #5 :) Sorry it’s an attachment.

Sorry about that. Did not see it.

Edit: You should not need any special driver because it looks like they are using the same chip as a genuine Arduino Uno.

Have you tried disabling anti-virus. There was also some talk about driver authentication for Windows 10 that can cause a problem.

I didn't have that with my Windows 10 Pro 64-bit install though.

I haven’t tried disabling the antivirus yet.. I have however tried disabling driver signature enforcement.. that also failed.. I plugged this board into a Mac at work ( very new ), and it did give me an option for port, but there was only one choice, some kind of Bluetooth port... I wasn’t able to make it work on the Mac either, but I didn’t spend more than 30 minutes investigating.

The computer has an upgraded video card as well as a SSD (which it did not come with). I’m also using a gaming keyboard which uses up 2 USB ports. Aside from that, nothing has been upgraded. It’s probably not relevant, but I figure it can’t hurt to mention. Again, thank you guys for taking the time to help me out here.

Your upgrades should not change anything in relationship to the Arduino so it should be safe to discount those.

That you installed those other drivers will not harm either and may prove useful if you get a clone so we can rule those out too.

Lets step back a little bit as you should be able to see something in device manager.

Here is a screenshot from my win 10 box.

10 com and lpt.png

You should be seeing something under com & lpt ports.

If you dont see a UNO in the comport section or a device with an error at the very least. its almost safe to assume there is a major problem with the board

Here is my device manager with hidden…
I cant even see any COM ports…

Try this as it has fixed some issues in the past.

Open "Device Manager" Select menu "Action" -> "Add legacy hardware", then Click "Next" Select "Install the hardware that I manually select from a list (Advanced)" -> then click "Next" Scroll down, then select "Ports (COM & LPT)", then click "Next" Select "Manufacturer" as your need, (in this case, I'm selecting standard type or default option) then click "Next"

Also you might need to check you computers BIOS to see if ports are enabled.

Its been an issue with windows 10 for a lot of people and its not just Arduino either. People with a few other devices, printers etc,

Ok. I’m going to try that idea. I also checked bios a few days ago and there wasn’t any options for ports :/

View > Devices by connection is also a good idea.

so I gave this a shot… I posted some screenshots of the results…

Capture.PNG

Capture3.PNG

OK so you have moved ahead and now have COM ports.

Code 10 is usually a quick fix but doing a driver update. Select the device properties and do a driver update from there but try with driver signing OFF ! Also a computer restart might help.