Windows 10 won't recognize device to install driver

I have a Arduino UNO R3 that came with a "Creation Crate" "Mood Lamp" kit.
I have been trying everything I can think of to get my laptop to install the drivers but to no avail.

I am using windows 10 on a HP EliteBook 8530P. I have installed Arduino 1.8.15, and plugged in my arduino UNO R3. Windows claimed device installed and was ready to use, but upon going to device manager, I could not find Arduino in COM port section, instead it loads in "other devices" USB-serial, I clicked update drivers, and pointed it at C:\Program Files\Arduino\drivers\ but I got the response "Windows was unable to install your USB-serial, windows could not find driver software for your device. What can I do next?

Probably it's a clone with CH340 chip. If so, download CH341Ser.zip from the Chinese website, unzip it and execute the exe.

Direct link: CH341SER.ZIP - Nanjing Qinheng Microelectronics Co., Ltd.

// edit
Windows device manager should be able to tell you which chip is involved when looking at the properties of the usb-serial.

It is a CH340, so that driver worked.

Thanks!

1 Like

To let others know that your problem was solved, click the solution checkbox under the most useful reply.